Home | Tutorials | Wiki | Issues
Ask Your Question
0

libgazebo9-dev unmet dependencies (ubuntu 18.04)

asked 2019-08-02 03:44:18 -0500

denzel gravatar image

Hello, I am trying to install gazebo9 on ubuntu 18.04 but I am facing some unmet dependencies errors. Initially I tried running the one-liner command curl -sSL http://get.gazebosim.org | sh but it threw the error,

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libgazebo9-dev : Depends: libgazebo9 (= 9.10.0-1~bionic) but it is not going to be installed
                 Depends: gazebo9-plugin-base (= 9.10.0-1~bionic)
E: Unable to correct problems, you have held broken packages.

So I tried to manually install the dependencies libgazebo9 and gazebo9-plugin-base with sudo apt install and it was successful. With both libgazebo9 (version 9.10.0-1~bionic) and gazebo9-plugin-base (version 9.10.0-1~bionic) successfully installed, I tried to install run the one-liner command again but it is still throwing the same error that the dependencies are not met when I have installed the dependencies already.

I have also tried to manually install libgazebo9-dev but it is also throwing the same error that the dependencies are not met. Have anyone come across this error before? Thanks.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-08-05 09:57:47 -0500

bhej gravatar image

Every time I have had this problem, the issue was with the libignition-math not installing.

Try to run this line then installing Gazebo 9:

sudo apt-get install libignition-math4-dev

edit flag offensive delete link more

Comments

hello bhej, I have tried installing libignition-math4-dev, but I am still facing the same error.

denzel gravatar imagedenzel ( 2019-08-06 00:15:02 -0500 )edit

I would recommend following the error. Try to install every package that says it is not going to be installed. Eventually you will get to the culprit (when it installs). Then run the gazebo9 installation.

bhej gravatar imagebhej ( 2019-08-06 11:03:30 -0500 )edit

I did try to follow the error. The only errors that pops up when trying to download libgazebo9-dev, are the unmet dependencies errors (both libgazebo9 and gazebo-plugin-base). Even after I successfully downloaded those two dependencies, libgazebo9-dev is still saying that I have unmet dependencies.

denzel gravatar imagedenzel ( 2019-08-07 02:43:41 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-08-02 03:44:18 -0500

Seen: 191 times

Last updated: Aug 05