Home | Tutorials | Wiki | Issues
Ask Your Question
0

Unable to install gzweb on ubuntu 18.04

asked 2019-08-20 18:41:54 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I first installed gazebo9 and verified it runs after entering 'gazebo'

Then I followed the setup procedure for installing gzweb from here: http://gazebosim.org/tutorials?cat=gz...

The versions of the dependencies are:

  • libjansson-dev is already the newest version (2.11-1).
  • libboost-dev is already the newest version (1.65.1.0ubuntu1).
  • imagemagick is already the newest version (8:6.9.7.4+dfsg-16ubuntu6.7).
  • libtinyxml-dev is already the newest version (2.6.2-4).
  • mercurial is already the newest version (4.5.3-1ubuntu2.1).
  • cmake is already the newest version (3.10.2-1ubuntu2.18.04.1).
  • build-essential is already the newest version (12.4ubuntu1).
  • nodejs is already the newest version (8.10.0~dfsg-2ubuntu0.4).
  • npm is already the newest version (3.5.2-0ubuntu4)

running './deploy.sh -m' yielded the error:

CMake Error at CMakeLists.txt:38 (find_package):
  By not providing "Findgazebo.cmake" in CMAKE_MODULE_PATH this project has
  asked CMake to find a package configuration file provided by "gazebo", but
  CMake did not find one.

One post indicated the way to fix this error is to install 'libgazebo9-dev'. Unfortunately, installing this will remove the following packages:

libcurl4-gnutls-dev libssl1.0-dev node-gyp nodejs-dev npm

Another post indicated the following commands were able to fix his similar error:

curl -sL https://deb.nodesource.com/setup_8.x | sudo bash -
sudo apt-get install -y nodejs

This caused version 8.16.1 of nodejs to be loaded instead of 8.10.0. Now, however, when I try to install npm, it indicates it can't install because there are unmet dependancies:

npm : Depends: nodejs but it is not going to be installed
      Depends: node-abbrev (>= 1.0.4) but it is not going to be installed
      ...
      Depends: node-which but it is not going to be installed

And nodejs won't install without nodejs-dev, which won't install without libssl1.0-dev. If I then install libssl1.0-dev, I see that it will uninstall 'libgazebo9-dev'. So if I proceed with this, nodejs, nodejs-dev and libssl1.0-dev are all installed, but libgazebo9-dev is uninstalled and I again get the same error I originally got when I try to run ./deploy.sh -m

CMake Error at CMakeLists.txt:38 (find_package):
  By not providing "Findgazebo.cmake" in CMAKE_MODULE_PATH this project has
  asked CMake to find a package configuration file provided by "gazebo", but
  CMake did not find one.

Does gzweb not work with gazebo9 on ubuntu 18.04, or is this some setup issue I have? Thanks

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-08-21 11:11:05 -0500

dmcd2356 gravatar image

By the way, the full error comment that I get is:

CMake Error at CMakeLists.txt:38 (find_package):
By not providing "Findgazebo.cmake" in CMAKE_MODULE_PATH this project has
asked CMake to find a package configuration file provided by "gazebo", but
CMake did not find one.

Could not find a package configuration file provided by "gazebo" with any
of the following names:

  gazeboConfig.cmake
  gazebo-config.cmake

Add the installation prefix of "gazebo" to CMAKE_PREFIX_PATH or set
"gazebo_DIR" to a directory containing one of the above files.  If "gazebo"
provides a separate development package or SDK, be sure it has been
installed.

Neither of these files are present in the /usr/share/gazebo-9 directory. This only consists of a setup.sh file and the subdirectories: media, models and worlds, none of which contain the cmake files either.

Also, my environment does not include either of the CMAKE_xxx_PATH settings. Should these be set to something?

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-08-20 18:41:54 -0500

Seen: 21 times

Last updated: Aug 21