Home | Tutorials | Wiki | Issues
Ask Your Question
0

run gazebo in virtualbox

asked 2012-09-28 13:31:37 -0500

nkoenig gravatar image

I have a project that I'm working on which I will use Gazebo to model robots. I have installed VirtualBox on my Macbook (Mac os x) and installed two different ubuntu distributions, and installed Gazebo on each of them, on both installations, I have faced with problems and was not able to install in one step although I followed every step in the instructions for ubuntu.

I would appreciate if you can let me know of the version(and the bit, 32 or 64) of Ubuntu which works best with the Gazebo so I can install that version and install Gazebo on that. I have tried the last version of Ubuntu which is 12.04 and 11.10. ( I think both of them were 64 bit distributions)

edit retag flag offensive close merge delete

10 Answers

Sort by » oldest newest most voted
1

answered 2012-09-28 13:32:48 -0500

nkoenig gravatar image

The biggest problem is running Gazebo in a virtual machine. I've never had any luck with this kind of setup.

The best solution is to setup a dual boot where your second OS is the latest Ubuntu. Then you'll be able to run Gazebo just fine.

edit flag offensive delete link more
2

answered 2013-07-24 13:30:03 -0500

Carlos Agüero gravatar image

updated 2013-07-24 13:59:19 -0500

That's not a recent topic but I just let you know that gazebo works in Ubuntu 12.10 under VirtualBox. However, I was not able to make it run with a decent performance in Ubuntu 12.04.

Some extra notes:

  • Enable 3D Acceleration (On your host VirtualBox settings->Display->Video).
  • Install VirtualBox Oracle VM VirtualBox Extension Pack.
  • Install the gnome-session-fallback package on your guest. Make sure you select this desktop when you log in the next time. The performance will be better compared with Unity.
  • Do not install the guest additions.

I've tried with Gazebo 1.9.x and it is usable.

Enjoy!

edit flag offensive delete link more
1

answered 2018-10-13 02:58:15 -0500

m1kelyons gravatar image

Setup

  • Dell Inspiron 7520 Laptop
  • Windows 7 / 10
  • Oracle VirtualBox 5.2.18
  • Ubuntu 16.04 LTS VM
    • Settings -> Display -> 3D Hardware Acceleration Enabled
  • Gazebo7

Fix

Change BIOS Settings If laptop has hybrid GPUs switch to only discrete GPU (nVidia/AMD), otherwise skip. Note: This may not be required.

  1. Enter BIOS, Enable Discrete GPUs which disables hybrid (will consume more power)
  2. When booted, system (Windows host) will automatically update drivers, then reboot

Setup VM

  1. Install packages

     sudo apt remove libcheese-gtk23
     sudo apt install xserver-xorg-core
    
  2. Reboot VM

Troubleshooting VM

If you lose mouse and keyboard after the previous step:

  1. Reboot VM, on startup hit the Esc or Shift keys to enter grub startup menu
  2. Select _Advanced Options_
  3. Select _Ubuntu-Kernel-xxxxx (recovery)_ (Should be the first recovery option)
  4. Select _Network_ to get network access
  5. Select _Drop to root shell_
  6. Install mouse and keyboard packages

     apt install xserver-xorg-input-all
    
  7. Press Ctrl-D to leave root shell

  8. Select _Resume_
edit flag offensive delete link more
0

answered 2014-01-06 11:34:47 -0500

scpeters gravatar image

This is slightly off-topic, but I noticed that you are using a Mac laptop, and we have been improving native Mac OSX support for Gazebo in case you are interested in that option.

edit flag offensive delete link more
0

answered 2014-01-04 06:04:03 -0500

JanBrogger gravatar image

updated 2014-01-04 06:04:49 -0500

FWIW, Gazebo works like a charm with the following setup:

  • Host OS: Windows 7 Premium 64-bit

  • Host machine: 32 Gb RAM, Intel i7 2.8 GHz, CPU 4-core, 8-thread, SSD disk

  • Virtualizer: VMWare Workstation 9

  • Virtual machine: 8 Gb RAM, 20 Gb storage, 2 processors x 2 cores, 3D acceleration on

  • Virtual OS: Ubuntu 13.10.

  • Gazebo version: 2.1.0

Just followed the instructions.

edit flag offensive delete link more
0

answered 2012-10-11 12:07:00 -0500

marcomurk gravatar image

Talking about Gazebo and virtual machines, it worth noticing that (at least) the stand-alone version of Gazebo 1.0.1 for Ubuntu 12.04 32-bit works SLOWLY but (as far as I know) fine in a VMware Player environment.

edit flag offensive delete link more
0

answered 2012-10-25 15:14:42 -0500

Sameer Parekh gravatar image

I have a 4-core Mac with 10.7 and VMWare Fusion 5, Ubuntu 12.04 -- it works fairly well on 32-bit, but I haven't gotten it to work on 64-bit. Every now and then the gazebo or rviz window doesn't show me graphics (just a black window) and sometimes gazebo just crashes on startup. Performance is reasonable.

edit flag offensive delete link more
0

answered 2012-10-25 00:47:49 -0500

tkoolen gravatar image

updated 2012-10-29 11:34:28 -0500

Our experience with using virtual machines is as follows:

  • Ubuntu 12.04 on VirtualBox with Windows 7 host: works, but choppy graphics; well below real-time simulation rate on recent HP Envy laptop (don't remember exact number)
  • Ubuntu 12.04 on Parallels with OS X host: works, but choppy graphics, 0.4 real-time rate on latest 15 inch Macbook Pro with DRCSim

No trouble installing on either system. By the way, the VirtualBox image found at http://www.ros.org/wiki/ROS/Installation did not work for me (error on import with OS X host).

edit flag offensive delete link more

Comments

Yes. The virtualbox image does not work. It should be scrapped in my opinion.

nareshshah139 gravatar imagenareshshah139 ( 2012-10-31 11:29:34 -0500 )edit
0

answered 2012-10-09 20:50:34 -0500

SL Remy gravatar image

updated 2012-10-25 13:23:47 -0500

Running Snow Leopard on dual core MBP, I use VirtualBox 4.1.20 (kinda slow to upgrade), Ubuntu precise 32 bit, I live in ROSland so my current install is from debs, but I did test an install from source a couple of versions ago.

This is also running on a Kubuntu guest, and on a Windows 7 host (VB 4.2.0) on a Dell Optiplex 755.

edit flag offensive delete link more
0

answered 2013-11-22 18:44:02 -0500

I have NOT had success running Gazebo under the following configuration:

  • Gazebo 1.9
  • Ubuntu Desktop 12.04.3 64-bit (guest)
  • List item
  • VirtualBox 4.3.0 r89960
  • Windows 7 Home Premium 64-bit (host)
  • VirtualBox 3D acceleration enabled

I get error messages similar to the following:

eOpenGL Warning: glFlushVertextArrayRangeNV not found in mesa table

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2012-09-28 13:31:37 -0500

Seen: 13,339 times

Last updated: Oct 13