Home | Tutorials | Wiki | Issues
Ask Your Question
0

Stained STL files in Gazebo (on 64 bit system)

asked 2013-04-30 12:16:25 -0600

Wonyoung gravatar image

Recently, I have reinstalled 64 bit ubuntu on my machines to use drcsim properly. However, I cannot fix the stains on STL files. I captured a irobot hand in the gazebo as the below.

https://www.dropbox.com/s/m73qanoupd2...

When I used 32 bit one, there was no problem with it. My graphic card is ATI Mobility Radeon HD 3400 Series (lenovo T400) and it uses basic builtin graphic card driver of ubuntu 12.04. I found the same problem in my another desktop which uses ATI Radeon HD 2400. I don't know how many times I reinstalled the OS and graphic card drivers. Please help me to solve this problem.

edit retag flag offensive close merge delete

Comments

can you convert it to a collada dae file and try load it with Gazebo to see if it makes a difference?

iche033 gravatar imageiche033 ( 2013-05-07 22:35:08 -0600 )edit

I think it only happens on STL files. Other collada dae files work fine. I have tried to set some material and color properties but no luck. In my case, the collada file format increases its file size and I don't want to use it. If there is no choice, I should export my files to collada format.. However, I think it'd better to know the reason and my fault on my machine settings.

Wonyoung gravatar imageWonyoung ( 2013-05-07 22:49:09 -0600 )edit

It could be a Gazebo's stl loader issue. The collada loader in Gazebo is more up-to-date so I would suggest using .dae files.

iche033 gravatar imageiche033 ( 2013-05-10 00:15:50 -0600 )edit

Can you post your stl file?

nkoenig gravatar imagenkoenig ( 2013-07-23 18:54:02 -0600 )edit

As you can see the image I linked in the question, it is a iRobot hand from the gazebo model DB. If you let me know to extract my computer setting information, I can provide every information for you.

Wonyoung gravatar imageWonyoung ( 2013-08-20 15:56:44 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2014-02-21 16:48:30 -0600

nkoenig gravatar image

This is being tracked with this issue

edit flag offensive delete link more
0

answered 2013-09-15 19:13:20 -0600

nkoenig gravatar image

updated 2013-09-15 19:13:42 -0600

Can you try disabling shadows? You can do this via the Gazebo gui by selecting "Scene" in the World tab, and then toggle the shadows check-box below.

edit flag offensive delete link more

Comments

This method removes the stained things as well as the shadow and looks better than before. I can simulate without it. However, gazebo shuts down when I try to re-enable the shadow option. I think these issues might be related to my radeon GPU. Radeon GPUs are not really good for Gazebo. Currently, I need to try a couple of times to launch gazebo in my laptop due to the graphic card errors. It gets worse than before. It would be nice if I can change my GPU in my laptop...

Wonyoung gravatar imageWonyoung ( 2013-09-15 21:48:34 -0600 )edit
0

answered 2013-08-05 19:14:17 -0600

John Nagle gravatar image

That sort of graphics artifact usually indicates two triangles drawn on top of each other. Look for a bug which sends the same geometry to OpenGL twice.

edit flag offensive delete link more

Comments

The model is from the Gazebo model DB and other STL models from the DB show same error.

Wonyoung gravatar imageWonyoung ( 2013-08-20 15:58:50 -0600 )edit
Login/Signup to Answer

Question Tools

Stats

Asked: 2013-04-30 12:16:25 -0600

Seen: 341 times

Last updated: Feb 21 '14