Home | Tutorials | Wiki | Issues
Ask Your Question
0

Illegal instruction (core dumped)

asked 2012-10-01 01:53:00 -0500

Kazaud gravatar image

updated 2012-10-05 09:20:53 -0500

nkoenig gravatar image

Hello all, I'm fairly unskilled when it comes to installing software on linux and I usually struggle with it. So I got excited when I finally got gazebo installed. However when I attempt to run it I get an illegal instruction error. By running gdb I was able to see that this is caused by code in gazebo::common::Time::Set(double) () from /usr/lib/libgazebo_common.so.1. Does anybody have an idea on how to fix this? Any help would be greatly appreciated.

Additional info I am running Ubuntu. Description: Ubuntu 12.04.1 LTS Release: 12.04 Codename: precise

I had to manually build OGRE due to a missing Cg plugin. However I don't think this is related. It appears to load OGRE okay.

Here is the gdb session.

user@Azul:~$ gdb gzserver
Reading symbols from /usr/local/bin/gzserver...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/local/bin/gzserver 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
Traceback (most recent call last):
  File "/usr/lib/debug/usr/lib/x86_64-linux-gnu/libstdc++.so.6.0.16-gdb.py", line 62, in <module>
    from libstdcxx.v6.printers import register_libstdcxx_printers
ImportError: No module named libstdcxx.v6.printers
Gazebo multi-robot simulator, version 1.0.1
Copyright (C) 2011 Nate Koenig, John Hsu, Andrew Howard, and contributors.
Released under the Apache 2 License.
http://gazebosim.org

[New Thread 0x7fffecebd700 (LWP 12661)]
[New Thread 0x7fffe7fff700 (LWP 12662)]
Msg Waiting for master
Msg Connected to gazebo master @ http://localhost:11345
[New Thread 0x7fffdffff700 (LWP 12663)]
[New Thread 0x7fffdf7fe700 (LWP 12664)]
[New Thread 0x7fffdeffd700 (LWP 12665)]
[New Thread 0x7fffde7fc700 (LWP 12666)]

Program received signal SIGILL, Illegal instruction.
[Switching to Thread 0x7fffde7fc700 (LWP 12666)]
0x00007ffff7bc6271 in gazebo::common::Time::Set(double) () from /usr/lib/libgazebo_common.so.1
edit retag flag offensive close merge delete

Comments

Would you be able to compile gazebo in debug mode, and then post a back trace? Instructions for compiling gazebo in debug mode can be found here: http://gazebosim.org/wiki/help.

nkoenig gravatar imagenkoenig ( 2012-10-05 09:43:50 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-10-18 10:45:41 -0500

nkoenig gravatar image

Version 1.2 of gazebo should have this problem fixed.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

Stats

Asked: 2012-10-01 01:53:00 -0500

Seen: 904 times

Last updated: Oct 18 '12