Home | Tutorials | Wiki | Issues
Ask Your Question
0

added model to gazebo models database cannot be lauched from world file or inserted from the insert model interface on the GUI ??

asked 2013-05-24 13:14:38 -0500

Zahra gravatar image

Hello ,

I was trying to follow the simple gripper tutorial http://gazebosim.org/wiki/Tutorials/1...robot/simplegripper

by creating a folder that contains my .sdf model and the .config file and adding it to ~/.gazebo/models .

And then I created the world file as following to launch my model from it :

  <sdf version="1.4">
    <world name="default">

<include> <uri>model://ground_plane</uri>

  </include>

  <include>
     <uri>model://sun</uri>
  </include>

  <include>
     <uri>model://apartment_floor0</uri>
  </include>

    </world>
  </sdf>

the problem is when I start gazebo with this world file , only ground plane and sun models show up. And then I tried another way to launch the model by running gazebo and importing the model through the insert model interface on the GUI but the model is not there.

I also added the uri file of the model in the database.config file in the ~/.gazebo/models directory. Can anyone please tell me what am I missing or what could be went wrong ? Because I believe I have followed the instructions on the simple gripper tutorial pretty much well. thanks in advance!

edit retag flag offensive close merge delete

Comments

1

Could you post your .config file, or double check that the names corespond to the model you are trying to insert? What error message do you get when you try to insert it from the .world file? And do you add it in its own folder, as in ~/.gazebo/models/yourmodel/ ? Cheers

AndreiHaidu gravatar imageAndreiHaidu ( 2013-05-24 14:00:48 -0500 )edit

here is the model.config file :

<?xml version="1.0"?> <model><name>apartmentfloor0</name> <version>1.0</version> <gazebo version='1.4'>apartmentfloor0.sdf</sdf> <author><name>Zahraa</name><email>me@my.email</email> </author><description> empty apartment floor0. </description></model> I dont get any error messages except this warning that I got after I hav added the uri file in the database.config file that is existed in ~/.gazebo/models directoryInvalid filename or directory.

Zahra gravatar imageZahra ( 2013-05-24 14:27:06 -0500 )edit

Invalid filename or directory["/home/shahed.gazebo/models/database.config~"] in GAZEBOMODELPATH. It's not a good idea to put extra files in a GAZEBOMODELPATH because the file structure may be modified by Gazebo. I created a folder in ~/.gazebo /models directory called apartmentfloor0 , in this folder there's the model.config file which I posted, and the apartmentfloor0.sdf model.

Zahra gravatar imageZahra ( 2013-05-24 14:33:45 -0500 )edit

you could try not adding the model to the database.config file, I usually don't add them there, and it works for me

AndreiHaidu gravatar imageAndreiHaidu ( 2013-05-24 17:00:17 -0500 )edit

Thanks a lot , you are right about the tags. It works good now.

Zahra gravatar imageZahra ( 2013-05-25 02:06:48 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-05-25 00:44:05 -0500

scpeters gravatar image

It looks like there's an error in your model.config file. You have mismatched tags: <gazebo version="1.4">apartmentfloor0.sdf</sdf>

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

Stats

Asked: 2013-05-24 13:14:38 -0500

Seen: 1,731 times

Last updated: May 24 '13