Home | Tutorials | Wiki | Issues
Ask Your Question
1

spawning a robot from urdf with origin parameters through ros in gazebo 1.8

asked 2013-05-24 15:54:54 -0600

ffurrer gravatar image

Hi

I tried to upgrade from Gazebo 1.5 from source to Gazebo 1.8 from .deb package. And everything seemed to work fine also the ROS integration worked fine by using the simulator_gazebo package.

The only thing which didn't seem to work was spawning the robot model with an initial pose:

rosrun gazebo spawn_model -file robot.urdf -urdf -x 1 -y 1 -z 1 -R 3.1415 -P 0 -Y 0 -model robot

The robot got spawned in the world, but the initial position was ignored. I think it has to do with the urdf parser (parser_urdf.cc) which doesn't come with the ParseRobotOrigin function anymore. In gazebo_ros_api_plugin in the updateURDFModelPose function the origin_key gets both attributes xyz and rpy set correctly. so I assume that in gazebo this is not read correctly or it should be set differently now.

Does anyone have a solution for that, or should I file a bug?

Cheers Fadri

edit retag flag offensive close merge delete

Comments

Hi everyone, I noticed an issue that might be related with the one above. After setting the pose of a model (a box for example) in the .world file it is being spawned at the correct position but gazebo gui always says that it is at 0 0 0 0 0 0 pose. I tested with Gazebo 1.8, Gazebo 1.5 doesn't have this issue. Should I also report it as a bug? Thanks for help, Karol

khausman gravatar imagekhausman ( 2013-05-24 18:28:39 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-06-03 21:43:56 -0600

ffurrer gravatar image
edit flag offensive delete link more
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2013-05-24 15:54:54 -0600

Seen: 1,932 times

Last updated: Jun 03 '13