Home | Tutorials | Wiki | Issues
Ask Your Question
0

I using the gazebo 1.8.6 with ROS Groovy, but not load the spawn_model in the rxgraph.

asked 2013-06-24 14:10:33 -0500

EduardoMaciel gravatar image

updated 2013-06-27 20:51:35 -0500

Hi, I need some help to create my robot. My problem is publish the spawnmodel. I can't load the spawnmodel in the rxgraph, it appears and disappears soon after.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-06-24 17:17:39 -0500

davetcoleman gravatar image

I made this documentation that might help, although technically its for Gazebo 1.9 (unreleased) and the new gazeborospkgs, it is mostly the same for 1.8.6:

http://gazebosim.org/wiki/Tutorials/1...roslaunchFilestoSpawn_Models

edit flag offensive delete link more

Comments

Hi dave, I followed your tutorial, but I have a problem. When launching the command (roslaunch baxter_gazebo baxter_world.launch) initializes the gazebo, but it presents the following error: (Warning [parser.cc: 314] parse from urdf.). Using rxgraph can see that SpawnModel does not load, do you know what can be?

EduardoMaciel gravatar imageEduardoMaciel ( 2013-06-25 08:50:59 -0500 )edit

First, I believe you are using an older version of Gazebo. How did you install it? You should install it from source, for now, as described in http://gazebosim.org/wiki/Tutorials/1.9/Installing_gazebo_ros_Packages

davetcoleman gravatar imagedavetcoleman ( 2013-06-25 16:04:54 -0500 )edit

First, I believe you are using an older version of Gazebo. How did you install it? You should install it from source, for now, as described in http://gazebosim.org/wiki/Tutorials/1.9/Installing_gazebo_ros_Packages

davetcoleman gravatar imagedavetcoleman ( 2013-06-25 16:05:24 -0500 )edit

I reinstalled the Gazebo how describes the link (Compiling From Source / Download via Mercurial - hg clone https://bitbucket.org/osrf/gazebo gazebo and Compile Instructions - http://gazebosim.org/wiki/1.6/install # Compile_Instructions). When the gazebo is booting, he describes the version 1.8.6, is this the correct version?

Gazebo multi-robot simulator, version 1.8.6 Copyright (C) 2013 Open Source Robotics Foundation. Released under the Apache 2 License. http://gazebosim.org

EduardoMaciel gravatar imageEduardoMaciel ( 2013-06-27 08:15:35 -0500 )edit

The Baxter is initialized in Gazebo, but spawn_model node is finished alone and not show in the Rxgraph.

My error: [INFO] [WallTime: 1372335996.309722] [0.189000] Spawn status: SpawnModel: Successfully spawned model [spawnmodel-4] process has finished cleanly log file: /home/maciel/.ros/log/cdfa700c-df24-11e2-8d02-000c291d8a96/spawnmodel-4*.log

EduardoMaciel gravatar imageEduardoMaciel ( 2013-06-27 08:16:24 -0500 )edit

After installing the (gazeborospkgs) in the directory (~ / catkinws / src) and install Gazebo 1.8.6 from source, I need some further configuration to run the spawnmodel? My ~/.bashrc: source /opt/ros/groovy/setup.bash source /home/maciel/catkin_ws/devel/setup.bash source /usr/local/share/gazebo/setup.sh

EduardoMaciel gravatar imageEduardoMaciel ( 2013-06-27 10:12:24 -0500 )edit

Can you modify your question, above, with the command and launch file you are using to spawn model? Also, can you include a link to your model? Thanks.

davetcoleman gravatar imagedavetcoleman ( 2013-06-27 19:54:00 -0500 )edit
EduardoMaciel gravatar imageEduardoMaciel ( 2013-07-07 20:17:34 -0500 )edit

Hi Dave, do you have some news about the Spawn_model?

EduardoMaciel gravatar imageEduardoMaciel ( 2013-07-12 07:15:05 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2013-06-24 14:10:33 -0500

Seen: 316 times

Last updated: Jun 27 '13