Warning [RenderEngine.cc:691] Frame Buffer Objects (FBO) is missing

asked 2013-07-12 22:28:26 -0600

indranilsaha gravatar image

Hi,

I am running Gazebo using the following command:

gazebo /usr/local/share/gazebo-1.8/worlds/camera.world

And I am getting the following warnings


Gazebo multi-robot simulator, version 1.8.6Copyright (C) 2013 Open Source Robotics Foundation.Released under the Apache 2 License. http://gazebosim.org

Gazebo multi-robot simulator, version 1.8.6 Copyright (C) 2013 Open Source Robotics Foundation. Released under the Apache 2 License. http://gazebosim.org

Msg Waiting for master.Msg Waiting for master Msg Connected to gazebo master @ http://127.0.0.1:11345 Msg Publicized address: 128.32.171.243

Msg Connected to gazebo master @ http://127.0.0.1:11345

Msg Publicized address: 128.32.171.243

Warning [RenderEngine.cc:687] GLSL is missing.Fixed function rendering will be used.

Warning [RenderEngine.cc:691] Frame Buffer Objects (FBO) is missing. Rendering will be disabled.

Error [CameraSensor.cc:91] Unable to create CameraSensor. Rendering is disabled.

Error [CameraSensor.cc:91] Unable to create CameraSensor. Rendering is disabled.

Warning [RenderEngine.cc:687] GLSL is missing.Fixed function rendering will be used.

Warning [RenderEngine.cc:691] Frame Buffer Objects (FBO) is missing. Rendering will be disabled.


Also nothing is being displayed on the screen.

Can anyone help me figure out what I am doing wrong?

Thanks, Indranil

edit retag flag offensive close merge delete

Comments

what graphics card do you have and do you have the drivers installed?

iche033 gravatar imageiche033 ( 2013-07-15 13:15:02 -0600 )edit

the command 05:00.0 VGA compatible controller: NVIDIA Corporation G98 [Quadro NVS 420] (rev a1) 09:00.0 VGA compatible controller: NVIDIA Corporation G98 [Quadro NVS 420] (rev a1)

indranilsaha gravatar imageindranilsaha ( 2013-07-15 20:39:07 -0600 )edit

How can I know if I have the drivers installed? uname -a produces the following output: Linux VeriFun 3.2.0-45-generic #70-Ubuntu SMP Wed May 29 20:12:06 UTC 2013 x8664 x8664 x86_64 GNU/Linux

indranilsaha gravatar imageindranilsaha ( 2013-07-15 20:41:20 -0600 )edit

looks like you have a nvidia card, try: dpkg -l | grep nvidia-current and if it says ii at the beginning of the line then it's installed. Otherwise install the driver. Also make sure you have direct rendering: glxinfo | grep render should tell you.

iche033 gravatar imageiche033 ( 2013-07-16 12:28:35 -0600 )edit

Thank you. nvidia-current was not installed and I installed it. But glxinfo | grep render gives the following output:direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose) OpenGL renderer string: Intel HD Graphics 4000 OpenGL Engin. I could not figure out how I can enable direct rendering.

indranilsaha gravatar imageindranilsaha ( 2013-07-16 17:50:21 -0600 )edit

normally it should just load the nvidia module on reboot. Did you reboot your computer after you installed it? nvidia-settings may give some useful info

iche033 gravatar imageiche033 ( 2013-07-16 19:17:03 -0600 )edit

Rebooting the machine did not solve the problem. Still I am getting "direct rendering: No". When I am using nvidia-settings, I am getting "You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run nvidia-xconfig as root), and restart the X server." Is there anything wrong in a configuration file?

indranilsaha gravatar imageindranilsaha ( 2013-07-17 18:58:27 -0600 )edit

glxinfo | grep render gives the following output:direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose) OpenGL renderer string: Intel HD Graphics 4000 OpenGL Engin. I was thinking may be the graphics card is by Intel, not by Nvidia. Is there any command that can be used to confirm the graphics card in the system?

indranilsaha gravatar imageindranilsaha ( 2013-07-18 15:32:53 -0600 )edit

oh I thought you have nvidia card because in the second comment you wrote VGA compatible controller: NVIDIA Corporation G98 [Quadro NVS 420]. Try running lspci -v | grep -i nvidia, or lshw | grep -i nvidia and see if you have an nvidia device

iche033 gravatar imageiche033 ( 2013-07-18 16:44:10 -0600 )edit

Here is the partial output of lspci -v | grep -i nvidia

indranilsaha gravatar imageindranilsaha ( 2013-07-18 18:41:09 -0600 )edit