Home | Tutorials | Wiki | Issues
Ask Your Question
0

Warnings encountered while simulating erratic

asked 2012-12-04 22:01:53 -0500

ChengXiang gravatar image

updated 2012-12-19 01:15:25 -0500

Hi.I am using ROS fuerte on Ubuntu 12.04. While I was running erratic on gazebo, using

 roslaunch erratic_navigation_apps demo_2dnav_slam.launch

I encountered the following warnings.

[ WARN] [1354625870.495205787, 49.740000000]: Message from  
[/base_laser_self_filter] has a non-fully-qualified frame_id [base_footprint].  
Resolved locally to [/base_footprint].  This is will likely not work in 
multi-robot systems.  This message will only print once.
[ WARN] [1354625870.495682174, 49.740000000]: Message from 
[/base_laser_self_filter] has a non-fully-qualified frame_id [base_footprint]. 
Resolved locally to [/base_footprint].  This is will likely not work in 
multi-robot systems.  This message will only print once.
[ WARN] [1354625910.922358012, 65.418000000]: The /base_scan/marking observation 
buffer has not been updated for 0.24 seconds, and it should be updated every 
0.20 seconds.
[ WARN] [1354625988.636103668, 91.693000000]: The /base_scan/marking observation 
buffer has not been updated for 0.21 seconds, and it should be updated every 
0.20 seconds.
[ WARN] [1354625993.083708417, 93.493000000]: The /base_scan/marking observation 
buffer has not been updated for 0.20 seconds, and it should be updated every 0.20 
seconds.
[ WARN] [1354625996.023810230, 94.695000000]: The /base_scan/marking observation 
buffer has not been updated for 0.20 seconds, and it should be updated every 0.20 
seconds.

My question is how should I get rid of the warning for observation buffer. Thank you.

edit retag flag offensive close merge delete

Comments

Are you running link:this. I do not even get a robot spawned using the direct instructions. Did you change the robot description from urdf to sdf format?

Shanker Keshavdas gravatar imageShanker Keshavdas ( 2012-12-14 09:21:45 -0500 )edit

Hi Shanker. No i did not change the robot description.

ChengXiang gravatar imageChengXiang ( 2012-12-19 01:16:31 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-01-11 18:54:05 -0500

gerkey gravatar image

I suspect that you don't have enough CPU cycles and that as a result some part of the system is running slower than expected. Off-hand, I'm not sure whether it would be Gazebo itself (including plugins) or one of the ROS nodes.

In any case, have a look at your system load (e.g., with top). If your system is very busy, try having Gazebo run slower: lower <update_rate> in the .world file that you're using.

edit flag offensive delete link more

Comments

Thanks gerkey, i will try that. Looking back, I did realised that my PC will lag sometime when I run simulation.

ChengXiang gravatar imageChengXiang ( 2013-01-19 06:49:55 -0500 )edit
Login/Signup to Answer

Question Tools

Stats

Asked: 2012-12-04 22:01:53 -0500

Seen: 180 times

Last updated: Jan 11 '13