gzlog time stamp problem

asked 2013-08-13 18:15:51 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Dear Friends,

I was trying to take out the state variable data from state.log in ~/.gazebo/log/*/ using the command gzlog echo -r -s real --filter myrobot1.pose state.log. In the log, I found the following:

time_stamp x y z roll pitch yaw

Bt the time stamp only contains the "second" whereas in the sdf format, in real_time we have "seconds nanoseconds". Can anyone kindly suggest how can I get the nanosecond part as well? Otherwise for a long stream of data, the time remains 0 secs.

Thanks and Regards, Debjit.

edit retag flag offensive close merge delete

Comments

Can you post example output that demonstrates the problem? Also include the version of Gazebo you are using.

nkoenig gravatar imagenkoenig ( 2013-09-15 20:02:14 -0600 )edit

I have an exactly same problem. The time_stamp keeps showing '0' with 'sim' and 'real' options. For example. "0 -1.213 -1.061 0.325 0.146 0.073 0.009 " ~. With the 'wall' option, it shows "1.38937e+09 -2.92913 0.5697 0.32423 0.15707 0.01613 -0.23282", but the time stamp doesn't change. It's probably because the number is too big. My gazebo version is 1.9.2. Thank you.

Wonyoung gravatar imageWonyoung ( 2014-01-10 11:07:48 -0600 )edit