Home | Tutorials | Wiki | Issues
Ask Your Question
0

Defining material scripts in gazebo 1.9

asked 2013-08-14 06:29:34 -0600

abubeck gravatar image

Hi,

I'm trying to load my gazebo material scripts in gazebo 1.9 together with the gazebo_ros bridge. I'm not sure what is the right way to extend the resource_path. The export gazebo_media_path statements in the package.xml files don't seem to work. When manually creating the GAZEBO_RESOURCE_PATH variable the setup.sh file of the gazebo installation overwrites the environment variable I set. Copying the material scripts manually to /usr/share/gazebo1-9/... works fine, but this is only a hack.

Any ideas?

Thanks,

Alex

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-08-16 06:22:59 -0600

abubeck gravatar image

Thanks for your answer. I fixed it now for my installation. I did the following 2 mistakes:

1.) I used <gazebo gazebo_media_path .../> instead of <gazebo_ros gazebo_media_path .../> in my package.xml

2.) You have to define a <run_depend>gazebo_ros</run_depend> to get the export statement working.

The GAZEBO_RESOURCE_PATH unfortunally cannot be set manually because the script /usr/share/gazebo-1.9/setup.sh overwrites the variable.

edit flag offensive delete link more
1

answered 2013-08-14 06:45:09 -0600

adding this to my ROBOT_gazebo package.xml worked fine

<export>
    <gazebo_ros gazebo_media_path="/your/resource/path"/>
  </export>

if it does not work for you can can't you try export it extending the old values (for example at the end of your .bashrc or or the setup.sh file):

export GAZEBO_RESOURCE_PATH=$GAZEBO_RESOURCE_PATH:</your/path>
edit flag offensive delete link more
Login/Signup to Answer

Question Tools

Stats

Asked: 2013-08-14 06:29:34 -0600

Seen: 488 times

Last updated: Aug 16 '13