Home | Tutorials | Wiki | Issues
Ask Your Question
0

error when echo a rostopic when using gazebo_ros package for ros intergration approach.

asked 2013-08-16 09:43:38 -0500

Zahra gravatar image

Hello,

I am using the gazeboros packages to build my program with catkin packages and I am publishing two topics one of them I used sensormsgs::LaserScan , the other topic I built its message that the problem happen with. The problem is when I use "rostopic echo " on a topic that I built, I get the following error :

ERROR: Cannot load message class for [angen_gazebo/PirMsg]. Are your messages built?

I dont have a problem using a "rostopic info" in which I get the information of this topic. Also I can use “rosmsg show” and “rostopic info” to get the information of the topic.

Meanwhile there is another topic that I publish and am using sensor_msgs::LaserScan type and I can echo its topic without any problem as the previous one. Note: both topics showed when using rostopic list

Can anyone help me plz! thanks in advance.

edit retag flag offensive close merge delete

Comments

The problem is solved by rebuilding the message by editing CmakeList file dependency and building the project again and sourcing the setup.bash . ~/catkin_ws/devel/setup.bash

zahra gravatar imagezahra ( 2013-08-22 09:09:44 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2013-08-22 09:34:44 -0500

nkoenig gravatar image

Answer is in the comments.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

Stats

Asked: 2013-08-16 09:43:38 -0500

Seen: 1,215 times

Last updated: Aug 22 '13