Home | Tutorials | Wiki | Issues
Ask Your Question
0

DRCSIM doesn't start with roslaunch atlas_utils atlas.launch

asked 2013-08-21 01:00:00 -0500

Wonyoung gravatar image

Today, I updated all drcsim and gazebo and it's been 4 months since I used those. However, I couldn't start drcsim for some reason. It seems working at first, but it closes after launching the GUI. The below is the last part of the terminal msg. I think it's because of my GPU issue according to some previous questions. My laptops use radeon cards unfortunately. Please let me know how to get it work. I tried to change some drivers (Standard->proprietary->mesa utils), but no luck. I'm a very beginner and it'll be appreciated if someone can explain kindly to fix this issue. Thank you.

>>roslaunch atlas_utils atlas.launch
~~
setting /run_id to e3b3dee4-0a24-11e3-9efe-701a04203eba
process[rosout-1]: started with pid [9145]
started core service [/rosout]
process[gazebo-2]: started with pid [9159]
process[atlas_robot_state_publisher-3]: started with pid [9164]
process[multisense_sl_robot_state_publisher-4]: started with pid [9178]
process[tf2_buffer_server-5]: started with pid [9204]
process[multisense_sl/camera/stereo_proc-6]: started with pid [9234]
Warning [gazebo_main.cc:64] escalating to SIGKILL on client
[gazebo-2] process has finished cleanly
log file: /home/wonyoung/.ros/log/e3b3dee4-0a24-11e3-9efe-701a04203eba/gazebo-2*.log
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-09-15 18:44:33 -0500

nkoenig gravatar image

I'm not sure what version of Gazebo you're using, but could you try installing Gazebo 1.9 and then run gazebo?

If that fails, run gzserver and gzclient separately. Then generate a backtrace using gdb on whichever executable segafaults. Post the output of backtrace to this question.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2013-08-21 01:00:00 -0500

Seen: 136 times

Last updated: Sep 15 '13