Home | Tutorials | Wiki | Issues
Ask Your Question
0

DRCSim ROS Version Moving Forward

asked 2013-09-05 14:22:25 -0500

jhoare gravatar image

Prior to VRC we were using ROS Fuerte with DRCSim. It looks now from the roadmap ( http://gazebosim.org/wiki/DRC/Roadmap ) that this is no longer supported.

Am I correct in interpreting the roadmap that in order to use the "drcsim" package we will have to ourselves be using ROS Groovy?

Does this mean we can build drcsim from source and still use fuerte? Or will we be required to use groovy?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-10-28 14:48:36 -0500

Jose Luis Rivero gravatar image

Let me add my 0.2 cents.

Fuerte is now unsupported by upstream ROS, and although there are specific instructions to keep the system using drcsim-3.0 (still in Fuerte), I highly recommend move to Groovy (or newer) as soon as possible since starting with drcsim-3.2 new features won't be released under fuerte.

The problem for fuerte is that it lacks of fully catkin support and even compile drcsim from source will probably require you to modify the build system to back to rosbuild.

To avoid this migration problems and help with your decision about which platform to use, there is a draft of release plan sent today to gazebo mail list.

edit flag offensive delete link more
0

answered 2013-09-05 16:47:22 -0500

hsu gravatar image

updated 2013-09-06 16:20:37 -0500

Update

After some more discussion, we will hold off switch from fuerte to groovy with 3.0.0, Instead, we'll make the move to Groovy+Precise with 3.1.0 (to be release soon after 3.0.0).

Original Post (Deprecated)

You should be able to build drcsim 3.0.x from source against Fuerte. But moving forward, we are catkinizing drcsim in 3.1.x, so it will no longer be feasible to support Fuerte given Fuerte does not have proper catkin dependencies.

Is there something that you are using which requires Fuerte support?

edit flag offensive delete link more

Comments

All of our development thus far has been in fuerte, and we were not planning on upgrading before DRC. However from the sounds of it we will need to, in order to continue using the simulator.

jhoare gravatar imagejhoare ( 2013-09-06 08:23:28 -0500 )edit
Login/Signup to Answer

Question Tools

Stats

Asked: 2013-09-05 14:22:25 -0500

Seen: 379 times

Last updated: Oct 28 '13