Home | Tutorials | Wiki | Issues
Ask Your Question
0

libbullet not installed

asked 2013-09-25 01:26:32 -0500

David Jeang gravatar image

I'm attempting to do a manual install of a lower version of gazebo for a specific work environment.

Since I was working on a blank Ubuntu OS that never had gazebo installed. I first used sudo apt-get install gazebo,then sudo apt-get remove gazebo to keep the dependencies, but not the up-to-date version.

However, when I try to install the package I want, it goes like this:

sudo dpkg -i gazebo1.7.3-1~preciseamd64.deb Selecting previously unselected package gazebo. (Reading database ... 188459 files and directories currently installed.) Unpacking gazebo (from gazebo1.7.3-1~preciseamd64.deb) ... dpkg: dependency problems prevent configuration of gazebo: gazebo depends on libbullet; however: Package libbullet is not installed. dpkg: error processing gazebo (--install): dependency problems - leaving unconfigured Processing triggers for desktop-file-utils ... Processing triggers for bamfdaemon ... Rebuilding /usr/share/applications/bamf.index... Processing triggers for gnome-menus ... Errors were encountered while processing: gazebo

Apparently, there is still one dependency that wasn't added. How do I go about installing libbullet?

edit retag flag offensive close merge delete

Comments

Just to clarify. sudo apt-get install libbullet-dev did not work.

David Jeang gravatar imageDavid Jeang ( 2013-09-30 03:19:51 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-09-30 17:17:42 -0500

Jose Luis Rivero gravatar image

Looks like a problem with the libbullet version needed by gazebo.

While ubuntu ships 2.80, gazebo uses 2.81, so you will need to install debs from the OSRF repository. Two ways:

edit flag offensive delete link more

Comments

David Jeang gravatar imageDavid Jeang ( 2013-09-30 19:14:16 -0500 )edit

Right, but you have mixed the methods. Only with download and dpkg -i should be enough, you don't need to setup the repository if you are not going to use apt-get install to get the packages.

Jose Luis Rivero gravatar imageJose Luis Rivero ( 2013-10-02 17:01:19 -0500 )edit
0

answered 2013-09-25 11:45:46 -0500

nkoenig gravatar image

Can you install bullet using sudo apt-get install libbullet-dev?

edit flag offensive delete link more

Comments

I get this statement: The following packages have unmet dependencies: gazebo : Depends: libbullet but it is not going to be installed libbullet-dev : Depends: libbullet (= 2.81-2ppa1~precise) but it is not going to be installed

David Jeang gravatar imageDavid Jeang ( 2013-09-27 20:55:01 -0500 )edit
Login/Signup to Answer

Question Tools

Stats

Asked: 2013-09-25 01:26:32 -0500

Seen: 804 times

Last updated: Sep 30 '13