Player not found, gazebo plugin for player will not be built. Gazebo-2.0.0

asked 2013-10-08 01:51:55 -0600

PedroGusmao gravatar image

Hi, I am trying to install Gazebo 2.0.0 on Debian sid and CMake does not seem to find playerc++ although I have it installed.

Would it be possible to change CMake and make it look into the /usr/lib/player-3.0/ for the player libraries? This is the path for all player 3 libraries for Debian. I mean, how can I manually set the path inside CMakeLists to make it look into a path and not for a package name (which is assiciated to the Ubuntu distro)?

Thanks

edit retag flag offensive close merge delete

Comments

CMake uses pkg-config to find find playerc++ (cmake/SearchForStuff.cmake line 278). this should work on Debian too. If nobody has a better suggestion you could try to write your own .pc file for this. But this should have been done when you installed playerc++... maybe you just have to fix the PKG_CONFIG_PATH variable...

evilBiber gravatar imageevilBiber ( 2013-10-08 08:40:44 -0600 )edit

@PedroGusmao can you update your post with the output of `pkg-config --cflags --libs playerc++`

nkoenig gravatar imagenkoenig ( 2013-10-10 10:57:44 -0600 )edit