Home | Tutorials | Wiki | Issues
Ask Your Question
1

How to disable SkyX?

asked 2013-10-12 07:03:46 -0600

Norman.Hendrich gravatar image

Hi there,

I am running Gazebo on my brand-new Intel Core-i5 system - using the processor graphics (4670, Intel HD 4600). The volumetric SkyX cr*p is killing my system. Everything is working fine when looking down at the robot, but grinds to a halt when the stupid clouds come into view.

I don't need clouds, and I consider them annoying anyway. Our lab has a ceiling, and plain light gray background would be fine for me. Problem is, there is NOT one example on how to DISABLE the SkyX rendering in any world file, any Gazebo doc, any Google search I tried.

Removing the SkyX files crashes the simulator. Putting an empty <sky>whatever</sky> into my world file STILL loads SkyX.

Can I get rid of the clouds without recompiling everything?

Cheers, Norman

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-10-31 11:25:51 -0600

jbohren gravatar image

updated 2013-10-31 19:45:12 -0600

It looks like the only way to currently do it is to disable it in the source code. You can add these lines to the beginning of Scene::SetSky in gazebo/rendering/Scene.cc to disable it:

this->skyxController = NULL;
this->skyx = NULL;
return;

Also I created an enhancement ticket here: https://bitbucket.org/osrf/gazebo/iss...

UPDATE: It looks like in the latest branch of the gazebo source, the sky is disabled if your world doesn't have a <sky> tag.

edit flag offensive delete link more

Comments

Working on this now. A fix for 1.9 may be possible.

nkoenig gravatar imagenkoenig ( 2013-11-01 17:44:20 -0600 )edit

Here is a pull-request with the fix.

nkoenig gravatar imagenkoenig ( 2013-11-01 18:40:49 -0600 )edit
Login/Signup to Answer

Question Tools

Stats

Asked: 2013-10-12 07:03:46 -0600

Seen: 383 times

Last updated: Oct 31 '13