Home | Tutorials | Wiki | Issues
Ask Your Question
0

Error when loading plugins with gazebo2.0 [closed]

asked 2013-10-22 06:53:37 -0500

mikegao88 gravatar image

updated 2013-10-22 06:59:05 -0500

Hello! I have upgraded both gazebo (now as "gazebo-current" with the version of 2.0.0-2) and ros-hydro-gazebo-ros (now the version is 2.4.0-1precise) packages. My os is ubuntu precise 32bit. When I start the hector_quadrotor simulator, the gazebo can not find the plugins needed by the simulator:

Error [Plugin.hh:141] Failed to load plugin libhector-gazebo-ros-sonar.so: libgazebo_physics.so.1: cannot open shared object file: No such file or directory

Error [Plugin.hh:141] Failed to load plugin libhector-gazebo-ros-imu.so: libgazebo_physics.so.1: cannot open shared object file: No such file or directory

Error [Plugin.hh:141] Failed to load plugin libhector-gazebo-ros-baro.so: libgazebo_physics.so.1: cannot open shared object file: No such file or directory

Error [Plugin.hh:141] Failed to load plugin libhector-gazebo-ros-magnetic.so: libgazebo_physics.so.1: cannot open shared object file: No such file or directory

Error [Plugin.hh:141] Failed to load plugin libhector-gazebo-ros-gps.so: libgazebo_physics.so.1: cannot open shared object file: No such file or directory

Error [Plugin.hh:141] Failed to load plugin libhector-gazebo-quadrotor-simple-controller.so: libgazebo_physics.so.1: cannot open shared object file: No such file or directory

All these plugins are in this directory of my catkin workspace: /home/xxx/Workspace/catkin_ws/devel/lib, and I have also sourced the setup file of gazebo and exported the environment variables accordingly:

export GAZEBORESOURCEPATH=/home/xxx/Workspace:$GAZEBORESOURCEPATH

export GAZEBOPLUGINPATH=/home/xxx/Workspace/catkin_ws/devel/lib:$GAZEBOPLUGIN_PATH

Thanks for any help!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Jose Luis Rivero
close date 2013-10-28 14:59:54.272197

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-10-22 07:37:46 -0500

Jose Luis Rivero gravatar image

Gazebo 2.0 (gazebo_current) and ros-gazebo-pkgs version 2.4.0 (which works with gazebo_current) are not going to work with all the rest of packages in hydro depending on gazebo.

There is a new document explaining the Gazebo/ROS integration which should help to fix situations like yours. Please read it and feel free to comment if it is not useful at all.

edit flag offensive delete link more

Comments

Thanks! It seems that I have to reinstall everything related to ros and gazebo...

mikegao88 gravatar imagemikegao88 ( 2013-10-22 12:42:51 -0500 )edit

Things are in order again when I have reinstalled ros(hydro) and gazebo(1.9.1).

mikegao88 gravatar imagemikegao88 ( 2013-10-23 05:56:18 -0500 )edit

Question Tools

Stats

Asked: 2013-10-22 06:53:37 -0500

Seen: 1,431 times

Last updated: Oct 22 '13