Home | Tutorials | Wiki | Issues
Ask Your Question
0

Show joints option is showing the joints on wroong position

asked 2013-11-13 06:00:28 -0600

Garik gravatar image

updated 2013-11-13 06:01:41 -0600

Hi

So i have a robot that uses arms to do things. the arms are attached to motor models by a revolute joint. After showing the join location i noticed something odd.


=O=================

---

lets say that the O is where i set my joint to be. the arm then will rotate around that point if i add force to it. This works fine for the first arm. The second arm has the exsact same setup. however gazebo shows its joint to be like this

  ---

O =================== --- --- ---

however its showing the wrong position it does rotate around the right point that i set in my sdf file. This does get confusing as I have about 20 joints which may or may not be showing the wrong position.

is there a fix for this or am i doing something wrong?

edit retag flag offensive close merge delete

Comments

Could you post your SDF file? Also, what version of Gazebo are you using? There is a joint visualization fix in this [pull request](https://bitbucket.org/osrf/gazebo_models/issue/13).

nkoenig gravatar imagenkoenig ( 2013-11-13 15:26:57 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-11-14 03:52:50 -0600

Garik gravatar image

It turns out that rebooting my OS fixed the issue. It basicly came down to that gazebo was drawing the joints on wrong positions.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

Stats

Asked: 2013-11-13 06:00:28 -0600

Seen: 140 times

Last updated: Nov 14 '13