Home | Tutorials | Wiki | Issues
Ask Your Question
0

DRCSim + Precise + Hydro + roslaunch [closed]

asked 2014-01-21 16:45:00 -0500

davetcoleman gravatar image

updated 2014-01-21 16:45:25 -0500

I have Gazebo 3.0, gazebo_ros_pkgs-current, and the default branch of drcsim all compiling from source successfully with ROS Hydro and Ubuntu Precise. Now when I run

roslaunch drcsim_gazebo atlas.launch

I get a lot of errors in the terminal:

[atlasrobotstatepublisher-3] process has died [pid 3701, exit code -11, cmd /opt/ros/hydro/lib/robotstatepublisher/statepublisher jointstates:=/atlas/jointstates _name:=atlasrobotstatepublisher _log:=/home/dave/.ros/log/40b7e942-82ec-11e3-904a-d43d7e05aeaf/atlasrobotstatepublisher-3.log]. log file: /home/dave/.ros/log/40b7e942-82ec-11e3-904a-d43d7e05aeaf/atlasrobotstate_publisher-3*.log

[multisenseslrobotstatepublisher-4] process has died [pid 3714, exit code -11, cmd /opt/ros/hydro/lib/robotstatepublisher/statepublisher jointstates:=/multisensesl/jointstates _name:=multisenseslrobotstatepublisher _log:=/home/dave/.ros/log/40b7e942-82ec-11e3-904a-d43d7e05aeaf/multisenseslrobotstatepublisher-4.log]. log file: /home/dave/.ros/log/40b7e942-82ec-11e3-904a-d43d7e05aeaf/multisenseslrobotstatepublisher-4*.log

[tf2bufferserver-5] process has died [pid 3730, exit code -11, cmd /opt/ros/hydro/lib/tf2ros/bufferserver _name:=tf2bufferserver _log:=/home/dave/.ros/log/40b7e942-82ec-11e3-904a-d43d7e05aeaf/tf2bufferserver-5.log]. log file: /home/dave/.ros/log/40b7e942-82ec-11e3-904a-d43d7e05aeaf/tf2bufferserver-5*.log

[multisensesl/stereoproc-6] process has died [pid 3747, exit code -11, cmd /opt/ros/hydro/lib/stereoimageproc/stereoimageproc _name:=stereoproc _log:=/home/dave/.ros/log/40b7e942-82ec-11e3-904a-d43d7e05aeaf/multisensesl-stereoproc-6.log]. log file: /home/dave/.ros/log/40b7e942-82ec-11e3-904a-d43d7e05aeaf/multisensesl-stereo_proc-6*.log

[multisensesl/camera/stereoprocsimulationrelay-13] process has died [pid 4155, exit code -11, cmd /opt/ros/hydro/lib/stereoimageproc/stereoimageproc _name:=stereoprocsimulationrelay _log:=/home/dave/.ros/log/40b7e942-82ec-11e3-904a-d43d7e05aeaf/multisensesl-camera-stereoprocsimulationrelay-13.log]. log file: /home/dave/.ros/log/40b7e942-82ec-11e3-904a-d43d7e05aeaf/multisensesl-camera-stereoprocsimulation_relay-13*.log

Has DRCSim been tested with Hydro yet? What am I doing wrong? Thanks!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by davetcoleman
close date 2014-01-31 02:26:21.376855

Comments

looks like a bunch of ros nodes are not coming up properly. Did you source ${CMAKEINSTALLPREFIX}/share/drcsim/setup.sh before roslaunch?

hsu gravatar imagehsu ( 2014-01-21 17:05:29 -0500 )edit

Indeed, if you are using a catkin workspace, you should source install/setup.bash and install/share/drcsim/setup.sh

Jose Luis Rivero gravatar imageJose Luis Rivero ( 2014-01-21 17:28:25 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-01-31 02:25:42 -0500

davetcoleman gravatar image

This was due to an unrelated ROS core bug: https://github.com/ros/ros_comm/issues/342#issuecomment-33271508

edit flag offensive delete link more

Question Tools

Stats

Asked: 2014-01-21 16:45:00 -0500

Seen: 195 times

Last updated: Jan 31 '14