Home | Tutorials | Wiki | Issues
Ask Your Question
1

Problem installing GAZEBO on ubuntu 12.10 (broken package)

asked 2014-03-26 02:02:44 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hey guys, i was trying to install gazebo in my ubuntu 12.0, following the steps in "gazebosim.org/wiki/1.2/install" . However, after i input

sudo apt-get install gazebo

in terminal as step 4 suggested, it shows up the following errors:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gazebo : Depends: libboost-thread1.46.1 but it is not installable
          Depends: libboost-signals1.46.1 but it is not installable
          Depends: libboost-system1.46.1 but it is not installable
          Depends: libboost-filesystem1.46.1 but it is not installable
          Depends: libboost-program-options1.46.1 but it is not installable
          Depends: libboost-regex1.46.1 but it is not installable
          Depends: libboost-iostreams1.46.1 but it is not installable
          Depends: libcegui-mk2-0.7.5 but it is not installable
          Depends: sdformat (>= 1.4.7~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I've tried

sudo apt-get install -f

to fix it, but its still not working. Please, any suggestions or commnets will be appreciated XD

Eason.Lee

edit retag flag offensive close merge delete

Comments

1

Could you please update the answer with the output of these commands: "ls /etc/apt/sources.list.d/" ,"apt-get install sdformat" and "apt-get install libboost-iostreams1.46-dev". Thanks.

Jose Luis Rivero gravatar imageJose Luis Rivero ( 2014-03-27 18:05:31 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2014-11-17 09:05:33 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I'm on Precise not Quantal but I see a similar error.

$ sudo apt-get install gazebo
:
The following packages have unmet dependencies:
 gazebo : Depends: sdformat (>= 1.4.7~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

sudo apt-get install sdformat let me run sudo apt-get install gazebo without an error. Credit goes to @Jose Luis Rivero.

edit flag offensive delete link more

Comments

Glad to help! :)

Jose Luis Rivero gravatar imageJose Luis Rivero ( 2014-11-19 19:25:43 -0500 )edit
0

answered 2016-03-05 16:40:37 -0500

leEngineer gravatar image

I had the same problem! You can solve this makng:

sudo apt-get install <name_of_the_dependency>

Do it for all of them from the last to the first .

Ex.:

sudo apt-get install sdformat
.
.
.
sudo apt-get install libboost-thread1.46.1
edit flag offensive delete link more
Login/Signup to Answer

Question Tools

Stats

Asked: 2014-03-26 02:02:44 -0500

Seen: 1,598 times

Last updated: Nov 17 '14