Gazebo 1.9 slow rendering with collada (.dae) file

asked 2014-04-17 11:30:00 -0600

Il_Voza gravatar image

Hello guys, I have an issue: I made a 3D model by Sketchup, and I exported a collada file of size=25 MB (it is a 3D model of a Lab). When I make a my file .world where I put my file .dae, and I type "gazebo my_mesh.world" command, gazebo takes about 5 min to do to appear the model on simulation, and then the rendering is too slow. My pc is:

Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz

Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller

RAM 16 GB

I updated my graphic card driver following this tip: http://answers.gazebosim.org/question/2658/gui-rendring-is-very-slow/ , but nothing =(. How can I resolve? Thnx to all!

edit retag flag offensive close merge delete

Comments

This pull-request is probably relevant to your problem. We may be able to backport this to Gazebo 1.9

nkoenig gravatar imagenkoenig ( 2014-04-17 15:27:05 -0600 )edit

backport fix pull request is [here](https://bitbucket.org/osrf/gazebo/pull-request/1075/share-collada-vertices-19)

iche033 gravatar imageiche033 ( 2014-04-18 22:03:01 -0600 )edit