Home | Tutorials | Wiki | Issues
Ask Your Question
0

How do you completely uninstall old versions of gazebo?

asked 2014-04-18 03:36:20 -0600

gunnar gravatar image

updated 2014-04-20 01:23:12 -0600

scpeters gravatar image

Hi, I am new to gazebo, and I am trying to install gazebo through Homebrew on Mac OSX 10.8.5. I had an error when I installed gazebo 1.9.5, so rather than try to fix this error (which I think was just a missing program), I installed gazebo --HEAD, which I think should have given me gazebo 3.0. I compiled gazebo using catkin as instructed, but now this happens:


dhcp-5-248:~ gunnar$ gazebo
Gazebo multi-robot simulator, version 1.9.5
Copyright (C) 2014 Open Source Robotics Foundation.
Released under the Apache 2 License.
http://gazebosim.org

Msg Waiting for master.Gazebo multi-robot simulator, version 1.9.5
Copyright (C) 2014 Open Source Robotics Foundation.
Released under the Apache 2 License.
http://gazebosim.org

Warning [ModelDatabase.cc:335] Getting models from[http://gazebosim.org/models/]. This may take a few seconds.
....Warning [ModelDatabase.cc:206] Unable to connect to model database using [http://gazebosim.org/models//database.config]. Only locally installed models will be available.
Error [ModelDatabase.cc:408] Unable to download model[model://sun]
Error [SystemPaths.cc:371] File or path does not exist[""]
Error [parser.cc:528] Unable to find uri[model://sun]
Warning [ModelDatabase.cc:335] Getting models from[http://gazebosim.org/models/]. This may take a few seconds.
.....Warning [ModelDatabase.cc:206] Unable to connect to model database using [http://gazebosim.org/models//database.config]. Only locally installed models will be available.
Error [ModelDatabase.cc:408] Unable to download model[model://ground_plane]
Error [SystemPaths.cc:371] File or path does not exist[""]
Error [parser.cc:528] Unable to find uri[model://ground_plane]
Msg Waiting for master
Msg Connected to gazebo master @ http://127.0.0.1:11345
Msg Publicized address: 192.168.5.248
2014-04-18 10:22:56.839 gzserver[56504:707] invalid drawable

Msg Connected to gazebo master @ http://127.0.0.1:11345
Msg Publicized address: 192.168.5.248
2014-04-18 10:22:57.711 gzclient[56505:707] invalid drawable
2014-04-18 10:23:00.146 gzclient[56505:707] invalid drawable
Warning [ModelDatabase.cc:206] Unable to connect to model database using [http://gazebosim.org/models//database.config]. Only locally installed models will be available.

It appears as if gazebo is still 1.9.5. Sometimes I am able to connect to master, but most of the time I am not. How do I get rid of the older versions of gazebo? Or is there another problem that I should fix?

Homebrew doctor gives no warnings or errors.

Thank you for your help!

edit retag flag offensive close merge delete

Comments

Can you post the output of the following commands: `brew info sdformat`, `brew info gazebo`, `which gazebo`? This will help with debugging. Thanks.

scpeters gravatar imagescpeters ( 2014-04-20 01:27:38 -0600 )edit

4 Answers

Sort by » oldest newest most voted
0

answered 2014-04-24 16:42:23 -0600

scpeters gravatar image

Gazebo requires an internet connection in order to download model files (such as the sun and ground plane for the default world). If you don't internet access the first time you run gazebo, it will give this error. One option is to manually download model files from gazebosim.org/models and put them in your ~/.gazebo/models folder. Another option is to clone to the https://bitbucket.org/osrf/gazebo_models repository and place its location in the GAZEBO_MODEL_PATH environment variable. Let me know if this works for you.

edit flag offensive delete link more

Comments

Ok, thanks for your help! It seems to be working now. I have the models in the folder by cloning them. It must have been a combination of internet error on the first run and some other problem that must have resolved itself after rebuilding.

gunnar gravatar imagegunnar ( 2014-04-29 08:35:13 -0600 )edit
0

answered 2014-04-22 14:46:13 -0600

gunnar gravatar image

Ok, I have gazebo3.0.0 now, but a new error shows up:

dhcp-5-248:~ gunnar$ gazebo 2014-04-22 21:30:13.589 gzserver[11118:707] invalid drawable Error [parser.cc:528] Unable to find uri[model://sun] Error [parser.cc:528] Unable to find uri[model://ground_plane] 2014-04-22 21:30:22.569 gzclient[11119:707] invalid drawable 2014-04-22 21:30:24.273 gzclient[11119:707] invalid drawable

Gzclient opens, but I am unable to access models, and building a world and saving causes gzclient to crash.

edit flag offensive delete link more

Comments

What version of sdformat do you have? (`brew info sdformat`) We had a bug in sdformat, so you may need to rebuild it.

scpeters gravatar imagescpeters ( 2014-04-24 11:50:23 -0600 )edit

My version is: sdformat: stable 2.0.0, HEAD

gunnar gravatar imagegunnar ( 2014-04-24 13:33:51 -0600 )edit
0

answered 2014-04-21 19:19:55 -0600

scpeters gravatar image

updated 2014-04-22 02:44:44 -0600

According to brew info gazebo, you only have gazebo 1.9 installed. To remove it, do brew remove gazebo. To install gazebo 3.0, you need to do brew install gazebo3; there are separate formulae for each major version of gazebo. Currently:

  • gazebo: 1.9.5
  • gazebo2: 2.2.2
  • gazebo3: 3.0.0
edit flag offensive delete link more
0

answered 2014-04-21 14:36:36 -0600

gunnar gravatar image

updated 2014-04-21 19:17:33 -0600

scpeters gravatar image

Here is the info you asked for:


> hcp-5-248:~ gunnar$ brew info sdformat
sdformat: stable 2.0.0, HEAD
[http://gazebosim.org/sdf.html](http://gazebosim.org/sdf.html)
/usr/local/Cellar/sdformat/2.0.0 (188 files, 1.7M) *
  Built from source
/usr/local/Cellar/sdformat/2.0.1 (188 files, 1.7M)
  Built from source
From: [https://github.com/osrf/homebrew-simulation/commits/master/sdformat.rb](https://github.com/osrf/homebrew-simulation/commits/master/sdformat.rb)
==> Dependencies
Build: cmake ✔
Required: boost ✔, doxygen ✔, tinyxml ✔
> 
> dhcp-5-248:~ gunnar$ brew info gazebo
gazebo: stable 1.9.5, HEAD
http://gazebosim.org
/usr/local/Cellar/gazebo/1.9.5 (739 files, 57M) *
  Built from source
From: [https://github.com/osrf/homebrew-simulation/commits/master/gazebo.rb](https://github.com/osrf/homebrew-simulation/commits/master/gazebo.rb)
==> Dependencies
Build: cmake ✔, pkg-config ✔
Required: boost ✔, doxygen ✔, freeimage ✔, libtar ✔, ogre ✔, protobuf ✔, protobuf-c ✔, qt ✔, sdformat ✔, tbb ✔, tinyxml ✔
Optional: bullet ✘, ffmpeg ✘, player ✘
==> Options
--with-bullet
    Build with bullet support
--with-ffmpeg
    Build with ffmpeg support
--with-player
    Build with player support
--HEAD
    install HEAD version
> 
dhcp-5-248:~ gunnar$ which gazebo
/usr/local/bin/gazebo
edit flag offensive delete link more
Login/Signup to Answer

Question Tools

Stats

Asked: 2014-04-18 03:36:20 -0600

Seen: 6,765 times

Last updated: Apr 24 '14