Home | Tutorials | Wiki | Issues
Ask Your Question
0

Downloading models fails

asked 2014-06-05 03:09:28 -0500

timo gravatar image

Hi, I followed the instructions from http://gazebosim.org/tutorials/?tut=install to install gazebo into the local folder within my home directory under Ubuntu 14.04. Compilation and installing worked without significant problems. However, when I am now trying to run gazebo, I am observing the following (I removed the Publicized address):

$ gazebo --verbose
Gazebo multi-robot simulator, version 3.0.0
Copyright (C) 2012-2014 Open Source Robotics Foundation.
Released under the Apache 2 License.
http://gazebosim.org

[Msg] Waiting for master.
Gazebo multi-robot simulator, version 3.0.0
Copyright (C) 2012-2014 Open Source Robotics Foundation.
Released under the Apache 2 License.
http://gazebosim.org

[Msg] Waiting for master.
[Msg] Connected to gazebo master @ http://127.0.0.1:11345
[Msg] Connected to gazebo master @ http://127.0.0.1:11345
[Msg] Publicized address: xxx.xx.xx.xx
[Msg] Publicized address: xxx.xx.xx.xx
[Wrn] [ModelDatabase.cc:344] Getting models from[http://gazebosim.org/models/]. This may take a few seconds.
[Wrn] [gazebo.cc:239] Waited 1seconds for namespaces.
[Wrn] [gazebo.cc:239] Waited 1seconds for namespaces.
[Wrn] [gazebo.cc:239] Waited 1seconds for namespaces.
[Wrn] [gazebo.cc:239] Waited 1seconds for namespaces.
[Wrn] [gazebo.cc:239] Waited 1seconds for namespaces.
[Wrn] [gazebo.cc:239] Waited 1seconds for namespaces.
[Wrn] [gazebo.cc:239] Waited 1seconds for namespaces.
[Wrn] [gazebo.cc:239] Waited 1seconds for namespaces.
[Wrn] [gazebo.cc:239] Waited 1seconds for namespaces.
[Wrn] [gazebo.cc:239] Waited 1seconds for namespaces.
[Err] [gazebo.cc:244] Waited 11 seconds for namespaces. Giving up.
[Err] [Node.cc:98] No namespace found
[Err] [Node.cc:98] No namespace found
[Err] [Node.cc:98] No namespace found
[Err] [Node.cc:98] No namespace found
[Err] [Node.cc:98] No namespace found
[Err] [Node.cc:98] No namespace found
[Err] [Node.cc:98] No namespace found
[Err] [Node.cc:98] No namespace found
[Err] [Node.cc:98] No namespace found
[Err] [Node.cc:98] No namespace found
[Err] [Node.cc:98] No namespace found
[Err] [Node.cc:98] No namespace found
Error [Param.cc:181] Unable to set value [1,0471975511965976] for key[horizontal_fov]
Error [Param.cc:181] Unable to set value [0,100000001] for key[near]

Afterwards, the program quits.

Any help would be appreciated!

Thanks

Timo

edit retag flag offensive close merge delete

Comments

1

I've seen these errors too, but usually gazebo is still able to launch for me. Anyone know what the "no namespace found" means?

jonbinney gravatar imagejonbinney ( 2014-06-19 16:41:10 -0500 )edit

Seems as no one here is able to help me. Is there something else I could try to make gazebo work? Up to now, the experience is quite disappointing...

timo gravatar imagetimo ( 2014-06-27 05:42:26 -0500 )edit

Now,I've seen this problem too,but I have no idea that how to solve it,If there anyone know it,please contact me with 348129185@qq.com,thx

leo gravatar imageleo ( 2017-07-10 21:17:05 -0500 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2017-07-10 20:22:32 -0500

winston gravatar image

updated 2017-07-10 20:29:02 -0500

You can download these models yourself from here. And then put these models in /usr/share/gazebo-[VERSION]/models. For example, my Gazebo version is 7, so I put all these model files inside /usr/share/gazebo-7/models as shown below:
image description

Note that if you do not have these models, Gazebo should still work well; the only thing is that you need to wait long enough for the Gazebo GUI to appear. :)

edit flag offensive delete link more
0

answered 2017-07-09 02:38:54 -0500

I disconnected to Internet and worked well. but i dont know why but there's a connection problem ;-0

or edited both /usr/share/gazebo-2.2/setup.sh /usr/share/gazebo/setup.sh

from

export GAZEBO_MASTER_URI=http://localhost:11345

export GAZEBO_MODEL_DATABASE_URI=http://gazebosim.org/models

to

export GAZEBO_MASTER_URI=""

export GAZEBO_MODEL_DATABASE_URI=""

and

$ source /usr/share/gazebo-2.2/setup.sh

then worked fine

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

Stats

Asked: 2014-06-05 03:09:28 -0500

Seen: 1,671 times

Last updated: Jul 10