Shadows are permanently painted onto my Collada mesh visuals. Why and can I remove them?

asked 2014-07-03 15:49:50 -0600

I have used Blender to create a Collada DAE file from a surface STL file that my CAD program exports. When I use this DAE file as my mesh visual in my Gazebo robot model (SDF), the robot looks great from certain angles, but the shadow appears to be pained onto the mesh permanently. So for example a wheel will alternate between dark and light while turning in Gazebo, which looks rather silly and confusing to the viewer.

So is there a tag in the Collada DAE file that I can remove? Is there an SDF tag that I can use to ignore DAE texture? Is there a setting in Blender that I need to use to create a shadowless or textureless DAE file? If I remove the light source in Blender, won't the mesh be permanently painted black then?

I'm using Gazebo 1.9 and ROS Hydro.

edit retag flag offensive close merge delete