Home | Tutorials | Wiki | Issues
Ask Your Question
0

Settings for exporting collada (DAE) from Blender scene, specifically Human actors

asked 2014-07-09 21:05:06 -0500

Kalana gravatar image

updated 2014-07-09 21:36:15 -0500

Just wondering what specific options we need to have when exporting human characters designed in Blender to compatible with Gazebo actor animation.

Source code provided actor animation files (DAE) can be animated as shown by the original authors in link text. Now I want to have my own body movements transferred in to the default Gazebo character. To begin with, I imported one of collada file (moonwalk.dae) and tried to export the selected character back in to Collada and use in Gazebo. That fails for some reason. Simple comparison with original file shows differences in library_controllers, pose matrix, mesh positions, etc. I tried with various Collada export options (Texture, Data, etc) and still fails to. Before debugging in to, I would like to know if somebody has been successful in exporting Blender files previously when this feature was working?

I am using Blender 2.70, 64 bit Windows 7.

Thanks!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-07-09 21:39:21 -0500

Kalana gravatar image

updated 2014-07-09 21:40:20 -0500

Got it working! Actually missing of <library_controllers> was the major cause. Checked settings for getting it working are as follows. Could be helpful somebody else.

Export Data options: Selection Only, Include Children, Include Armatures

Texture options: Include UV Textures, Include Material Textures, Copy

Collada options: Triangulate, Use Object Instances, Transformation type: Matrix

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

Stats

Asked: 2014-07-09 21:05:06 -0500

Seen: 2,549 times

Last updated: Jul 09 '14