Mesh geometries using xacro not working with drcsim/Gazebo4 (working previously with drcsim/Gazebo2)

asked 2014-10-08 09:49:53 -0600

Stefan Kohlbrecher gravatar image

updated 2014-10-08 09:51:48 -0600

I made a small package for adding ar markers to robots using xacro and COLLADA files with embedded textures (vigir_ar_alvar_description). We previously used drcsim (df5dd3715cb5379f557b46bf8d369a53e4a850c4) as part of our workspace with Gazebo2 installed from .debs. With that setup, the AR markers showed up just fine.

We now switched to the new drcsim4 setup installed from .debs and the markers do not show up anymore. In fact, it seems that the mesh resource files are not found anymore by Gazebo, as both .stl and .dae geometries from the vigir_ar_alvar_description package just don´t show up in the model loaded by Gazebo at all. Replacing the mesh resources with box geometries, the links show up again. Gazebo does not complain in any way about the missing geoms.

The xacro file used is this one and it can be used like this:

<?xml version="1.0"?>

<robot xmlns:xacro="http://playerstage.sourceforge.net/gazebo/xmlschema/#interface" name="atlas" >
  <xacro:include filename="$(find vigir_atlas_description)/urdf/$(env VIGIR_ROBOT_TYPE).urdf"/>

  <!--New, add artag-->
  <xacro:include filename="$(find vigir_ar_alvar_description)/urdf/artag.urdf.xacro" />

  <xacro:artag parent="l_hand" name="artag_01">
    <origin xyz="-0.05 0 0.11" rpy="0 0 0"/>
  </xacro:artag>
</robot>

This is how things look in old drcsim: image description

In rviz, displaying the texture works in both setups: image description

In drcsim4,the link with the ar marker texture is missing completely: image description

Any ideas how to fix this are appreciated.

edit retag flag offensive close merge delete