Home | Tutorials | Wiki | Issues
Ask Your Question
1

DART support for Mac OS X?

asked 2014-11-10 22:17:25 -0600

site gravatar image

updated 2014-11-10 22:18:13 -0600

I'm running Gazebo on Mac OS X and I'd like to use the Dart physics engine.

When installing Gazebo, I followed the instructions to compile from source (http://gazebosim.org/tutorials?tut=install). Under "Compiling from Source (Mac OS X)" --> "Optional dependencies", it says to run "brew install gazebo4 --with-bullet --with-simbody", but makes no mention of how to install Dart.

Is this because there isn't Dart support for Mac OS X? Or is there some other command I can run to enable it?

Thanks very much!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2014-11-11 05:13:03 -0600

Jose Luis Rivero gravatar image

Looks like DART is providing a brew formulae, so you can try to patch the gazebo4 formulae to support the use of DART in MacOsX and, if it works for you, please send the Pull Request :)

edit flag offensive delete link more
0

answered 2014-12-02 16:03:07 -0600

scpeters gravatar image

There is dart support on OSX. You need to add an additional homebrew tap:


brew tap dartsim/dart
brew install dartsim --core-only

There is not yet a --with-dartsim option for gazebo due to some issues with homebrew. If you install dartsim before gazebo, then gazebo will find it.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

Stats

Asked: 2014-11-10 22:17:25 -0600

Seen: 207 times

Last updated: Dec 02 '14