Home | Tutorials | Wiki | Issues
Ask Your Question
0

Failed to load plugin libhector_gazebo_ros_imu.so

asked 2014-11-21 01:41:17 -0500

Ryo_Amano gravatar image

updated 2014-11-21 20:42:38 -0500

Hello! I'm using gazebo-2.2 with ros indigo and simulating our robot. But I have some problem with using IMU in my robot.

This is the source of IMU in my urdf.

image description

<gazebo reference="imu_link">
<sensor name="imu_sensor" type="imu"> <imu> <noise> <type>gaussian</type> <rate> <mean>0.0</mean> <stddev>2e-4</stddev> <bias_mean>0.0000075</bias_mean> <bias_stddev>0.0000008</bias_stddev> </rate> <accel> <mean>0.0</mean> <stddev>1.7e-2</stddev> <bias_mean>0.1</bias_mean> <bias_stddev>0.001</bias_stddev> </accel> </noise> </imu> <plugin name="imu_controller" filename="libhector_gazebo_ros_imu.so"> <robotNamespace>/infant2</robotNamespace> <frameName>imu_b</frameName> <bodyName>imu_link</bodyName> <topicName>imu_bottom/data</topicName> <alwaysOn>true</alwaysOn> <updateRate>50.0</updateRate> </plugin> </sensor> </gazebo>

but when I launch roslaunch myrobot_description myrobot.launch this error occurs.

Error [Plugin.hh:156] Failed to load plugin libhectorgazeborosimu.so: libhectorgazeborosimu.so: cannot open shared object file: No such file or directory

Also I already edited my ~/.bashrc and added

export GAZEBO_PLUGIN_PATH=~/my_ws:/opt/ros/indigo:${GAZEBO_PLUGIN_PATH}
export GAZEBO_MODEL_PATH=~/my_ws:/opt/ros/indigo:${GAZEBO_MODEL_PATH}
export GAZEBO_RESOURCE_PATH=~/my_ws:/opt/ros/indigo:${GAZEBO_RESOURCE_PATH}

does anybody knows how to solve ?

thank you for your regard.

Ryo.

I have tried with "libgazeborosimu.so" too . but other error occurs.

Error [Sensor.cc:236] Sensor[imu_sensor] is attempting to load a plugin, but detected an incorrect plugin type. Plugin filename[libgazebo_ros_imu.so] name[imu_controller] Service call failed: transport error completing service call: unable to receive data from sender, check sender's logs for details Segmentation fault (core dumped) [gazebo-1] process has died [pid 25298, exit code 139, cmd /opt/ros/indigo/lib/gazebo_ros/gzserver /home/amsl-ama/AMSL_catkin_ws/src/gazebo_ros_demos/rrbot_gazebo/worlds/rrbot.world __name:=gazebo __log:=/home/amsl-ama/.ros/log/87828712-67af-11e4-81ae-3c0754596049/gazebo-1.log]. log file: /home/amsl-ama/.ros/log/87828712-67af-11e4-81ae-3c0754596049/gazebo-1*.log

edit retag flag offensive close merge delete

Comments

Maybe the `GAZEBO_PLUGIN_PATH` needs `/opt/ros/indigo/lib` instead of just `/opt/ros/indigo`?

scpeters gravatar imagescpeters ( 2014-11-25 01:40:46 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-12-02 19:46:14 -0500

jackie gravatar image

If you want a brute-force solution, try:

sudo updatedb
locate libhectorgazeborosimu.so

to find the path to the dynamic library you are attempting to load. You may get multiple. Then add the folder containing libhectorgazeborosimu.so to your GAZEBO_PLUGIN_PATH using the command

export GAZEBO_PLUGIN_PATH=<absolute path to folder>:${GAZEBO_PLUGIN_PATH}
edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2014-11-21 01:41:17 -0500

Seen: 2,678 times

Last updated: Dec 02 '14