Home | Tutorials | Wiki | Issues
Ask Your Question
2

How do I update from the Fuerte Gazebo release to version 1.3

asked 2013-01-12 18:39:24 -0600

PMilani gravatar image

Hi All,

My version of Gazebo came packaged in the Fuerte release of ROS which I believe is 1.0. How do I go about updating it to 1.3. Because in the Gazebo installation tutorials, the ROS users are told not to install from here but are instead directed back to the ROS installation page, which as far as I know only packages Gazebo 1.0?

Is there a way to upgrade gazebo without touching or changing the remainder of my ROS files?

cheers

Peter

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
3

answered 2013-01-13 11:12:09 -0600

nkoenig gravatar image

I've fixed the gazebosim.org/wiki/install instructions. You should only install Gazebo from the OSRF repository. It will not touch your ROS files, and you will still be able to use ROS with Gazebo.

edit flag offensive delete link more

Comments

cheers I'll give it a go

PMilani gravatar imagePMilani ( 2013-01-13 18:29:11 -0600 )edit

I followed the directions but ran into issues using roslaunch. the problem has been listed here: http://answers.gazebosim.org/question/964/roslaunch-utilising-gazebo-10-not-gazebo-13/

PMilani gravatar imagePMilani ( 2013-01-21 18:12:37 -0600 )edit
0

answered 2013-01-12 20:39:56 -0600

ThomasK gravatar image

updated 2013-01-12 20:40:27 -0600

You can still follow the instructions, it won't change your ROS files. The only reason why ROS users are told to use the ROS package is that Gazebo itself is standalone and hence does not offer all the ROS plugins that are part of the simulator_gazebo stack and you might run into issues when trying to run old code/models.

Updated plugins that work with Gazebo 1.3 are part of the drcsim package which you can install additionally (i.e. simply follow the full drcsim install instructions). For launching gazebo within your launch file you'll then have to switch to the standalone executable instead of the gazebo inside the ros package (e.g. use the run_gazebo script in atlas_utils which starts gazebo with the ros api plugin loaded).

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2013-01-12 18:39:24 -0600

Seen: 803 times

Last updated: Jan 13 '13