Home | Tutorials | Wiki | Issues
Ask Your Question
0

Loading custom model

asked 2015-02-02 18:34:20 -0600

GenericUser gravatar image

I've been trying to follow the tutorial here to create a building model to place into my Gazebo world.

I can save the model file, but when I click done gazebo crashes. I figured this shouldn't be a problem as it creates the .sdf file anway.

However, when I try to load the model into fresh instance of gazebo, I cannot find the model. I have added the directory containing the .sdf file path into my GAZEBO_ MODEL_PATH env variable, so the directory does shown up under the models tab in Gazebo, however, there are no models listed here.

I had a look at default gazebo models folder in .gazebo and tried to match the folder structure using the .config files that come with the standard models, but to no avail.

I'm running Gazebo 1.96 (came with ROS Hydro), under Ubuntu 12.04 (I also tried it under OS X 10.10, although this is not my primary workstation)

edit retag flag offensive close merge delete

Comments

A lot of bugs on the Building Editor were fixed in the latest release, Gazebo 5. A lot of features were added too, here's the latest tutorial. I'd recommend you change to Gazebo 5 if possible.

Having that said, if you want to recover the building you've already made, sharing the SDF and config files might help.

chapulina gravatar imagechapulina ( 2015-02-02 18:43:55 -0600 )edit

Thanks chapulina, It looks like it was an issue with gazebo 1.96. I created a model on Gazebo 5 and it worked happily (I could open it in gazebo 1.96 as well!). I want to mark your comment as an answer/solved but I don't think I can unless its posted as an answer :/

GenericUser gravatar imageGenericUser ( 2015-02-04 19:45:15 -0600 )edit

Glad it worked out for you. I originally posted it as a comment because I think this doesn't solve the issue for Gazebo 1.96 users, but I copied it as an answer so you can close this question for now ;)

chapulina gravatar imagechapulina ( 2015-02-04 19:52:18 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-02-04 19:49:47 -0600

chapulina gravatar image

A lot of bugs on the Building Editor were fixed in the latest release, Gazebo 5. A lot of features were added too, here's the latest tutorial. I'd recommend you change to Gazebo 5 if possible.

Having that said, if you want to recover the building you've already made, sharing the SDF and config files might help.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

Stats

Asked: 2015-02-02 18:34:20 -0600

Seen: 2,225 times

Last updated: Feb 04 '15