Problems with support standing biped robot

asked 2015-02-21 07:17:52 -0600

Paulo Filho gravatar image

updated 2015-02-27 13:13:47 -0600

I have a robotic model modeled on URDF format. The model consists of only two hips connected by a chair and two legs, having active joints in the hips and knees. The joints of the ankles are passive. So far I finished this tutorial Gazebo http://gazebosim.org/tutorials/?tut=ros_comm. For now there are no errors with the XML description of the model. However, I have some questions. How can I to set the joints (hips and knees) of my biped to a pose when starting the Gazebo and this stand up, because when you start Gazebo he goes to the floor.

I already set values for the "effort" "friction" "damping" but that still did not work. In addition to already have defined a yaml controller for the joints of the hip and knees according with this tutorial http://gazebosim.org/tutorials/?=tut=ros_control.

I thank any help.

Here's informations when I launch my biprob.world and biprob_control: image description image description image description

Here are my model, world and controller

C:\fakepath\biprob.world C:\fakepath\biprob.gazebo.sdf C:\fakepath\biprob.urdf.xacro.sdf C:\fakepath\biprob_controller.yaml C:\fakepath\biprob.world

and my full project https://www.dropbox.com/sh/j7xggqvl649nlsy/AACmHq2d_BwdmqdDtRXEomCea?dl=0

edit retag flag offensive close merge delete

Comments

Can you share your model, world model and controllers? It's easier to see what's happening if either there's more detailed description for readers or if one can replicate the issue you are seeing. I recommend looking at the DRCSim robot tutorials http://gazebosim.org/tutorials?cat=drcsim for reference.

hsu gravatar imagehsu ( 2015-02-23 13:07:11 -0600 )edit

The configuration of my controllers I think are working properly. However when starting the Gazebo the robot still goes to the ground, but the joint controllers continue moving, I'm not sure why this because I do not have a concrete basis for my damping values in my model and values pid in controllers. Is there any tutorial to calculate these values, if that really is my problem? My Project https://www.dropbox.com/sh/j7xggqvl649nlsy/AACmHq2d_BwdmqdDtRXEomCea?dl=0

Paulo Filho gravatar imagePaulo Filho ( 2015-02-25 06:01:42 -0600 )edit

Thanks! without digging into the code at first, did you: 1) make sure the gazebo_ros_controller plugin is included in the model, 2) invoke http://wiki.ros.org/controller_manager commands to load and start the controllers?

hsu gravatar imagehsu ( 2015-02-26 11:54:16 -0600 )edit

Thanks! on biprob.gazebo I have the plugin gazeboroscontrol and on the biprobcontrol I have the node controllerspawner. I can see in the terminal that controls are loaded, but still the robot goes down to start the Gazebo.

Paulo Filho gravatar imagePaulo Filho ( 2015-02-26 12:34:58 -0600 )edit