Home | Tutorials | Wiki | Issues
Ask Your Question
0

hg clone = HTTP Error 400: Bad Request

asked 2013-01-16 05:10:30 -0800

dbworth gravatar image dbworth
1 3 3 5

updated 2013-01-17 00:26:06 -0800

$ hg clone https://bitbucket.org/osrf/gazebo gazebo

requesting all changes abort: HTTP
Error 400: Bad Request

Edit: but these two commands are okay:

$ hg clone https://bitbucket.org/osrf/gazebo-release
$ hg clone https://bitbucket.org/osrf/gazebo_models

And I can download the fuerte or john release ZIP file from the downloads page.

BitBucket has had some weird errors like this before... can someone try the commands please?

delete close flag offensive retag edit

4 Answers

Sort by ยป oldest newest most voted
1

answered 2013-01-16 15:05:28 -0800

nkoenig gravatar image nkoenig
4989 5 21 44
http://gazebosim.org/

Either bitbucket was down, or your network connection was. That command works for me.

link delete flag offensive edit

Comments

It could be a strange network error in our area, but it only seems to be on the gazebo repo.

dbworth ( 2013-01-17 00:26:55 -0800 )edit

I'm able to clone gazebo without a problem, and so are our continuous integration machines, which clone it many times per day to run tests. The problem might be at bitbucket's end, but without being able to reproduce it ourselves, I'm not sure how to help.

gerkey ( 2013-01-17 08:41:07 -0800 )edit

Okay, I checked from home, same error. Perhaps you guys can ask BitBucket to fix the repo? a quick Google search shows that error has appeared on other people's repo's. But, I guess most people compiling from source know how to get around this...

dbworth ( 2013-01-17 14:13:58 -0800 )edit

I've posted an issue at Bitbucket: https://bitbucket.org/site/master/issue/6015/user-unable-to-clone-osrf-gazebo. I'll comment back here if/when I hear something on it.

gerkey ( 2013-01-17 14:43:19 -0800 )edit

Can you clone another repo, such as https://bitbucket.org/osrf/drcsim?

nkoenig ( 2013-01-19 15:36:55 -0800 )edit
0

answered 2013-03-08 09:06:02 -0800

dejanpan gravatar image dejanpan
48 4 5 9

I had the same issue with "hg clone https://bitbucket.org/osrf/gazebo" at work today and then had to use the following command:

hg clone https://bitbucket.org/osrf/gazebo -r deprecatedparsersdf1.2support

link delete flag offensive edit
0

answered 2013-01-22 09:01:06 -0800

gerkey gravatar image gerkey
1384 7 17 23

Bitbucket support recommends that you open a ticket yourself:

Hello,

Since this is a repository-specific issue, I would ask that you (or the user experiencing the issue, preferably) submit a request to http://support.atlassian.com and we can work with them to resolve the problem there.

Thanks, Jon

https://bitbucket.org/site/master/issue/6015/user-unable-to-clone-osrf-gazebo

link delete flag offensive edit

Comments

Bitbucket who? The same error can be seen many times on Bitbucket's forums. Thanks for your concern @gerkey Anyway, it looks the masses aren't complaining. Maybe you guys might consider Github too.

dbworth ( 2013-02-01 11:33:43 -0800 )edit
0

answered 2013-02-01 11:29:35 -0800

dbworth gravatar image dbworth
1 3 3 5

Yes, I can clone drcsim too

link delete flag offensive edit

Login/Signup to Answer

Question tools

Follow

subscribe to rss feed

Stats

Asked: 2013-01-16 05:10:30 -0800

Seen: 446 times

Last updated: Mar 08 '13

Related questions