Home | Tutorials | Wiki | Issues
Ask Your Question
0

The oscillation of a joint with no command and zero gains [closed]

asked 2015-09-03 12:00:54 -0500

MahsaP gravatar image

updated 2015-09-25 05:51:30 -0500

Hi,

I have loaded my robot into Gazebo. This robot is 6 DOF. You can see the files from here. I have tuned PID parameters of ros_control for five joints. But, tuning joint 4 is not really easy. The behavior of joint 4 is strange too. When the input is in the following range (1.5<$input$<2 and -2<$input$<-1.5) the joint moves correctly. Otherwise, the error signal oscillates and the process_value signal does not oscillate. The reason to this issue is not clear to me.

Would you please give me a hint how to do that.

To run the code easily please enter the following lines:

1) run gazebo:

roslaunch denso_gazebo denso_world.launch

2) run rqt to show the figures and commands:

roslaunch denso_control denso_rqt.launch

The distro of my ROS is indigo running on Ubuntu 14.04.

Thank you.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by MahsaP
close date 2015-10-05 06:56:54.129925

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-10-05 06:56:32 -0500

MahsaP gravatar image

I found the problem. It had to do with the max and min of the joint.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2015-09-03 12:00:54 -0500

Seen: 327 times

Last updated: Oct 05 '15