How to eliminate a black screen while launching gazebo

asked 2015-09-09 01:02:08 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I have been using ROS Hydro. Whenever I try to launch Gazebo world only a black screen appears. All the graphic drivers in ROS are up to date. The system spec are: NVIDIA GEFORCE card with i5 processor.

I get this message while I run gazebo --verbose

:~$ gazebo --verbose Gazebo multi-robot simulator, version 4.1.3 Copyright (C) 2012-2014 Open Source Robotics Foundation. Released under the Apache 2 License. http://gazebosim.org

[Msg] Waiting for master. Gazebo multi-robot simulator, version 4.1.3 Copyright (C) 2012-2014 Open Source Robotics Foundation. Released under the Apache 2 License. http://gazebosim.org

[Msg] Connected to gazebo master @ http://127.0.0.1:11345 [Msg] Publicized address: 10.100.71.165 [Msg] Waiting for master. [Msg] Connected to gazebo master @ http://127.0.0.1:11345 [Msg] Publicized address: 10.100.71.165

edit retag flag offensive close merge delete

Comments

What version of Gazebo are you using? Could you try running gazebo in verbose mode (gazebo --verbose) and see if any error messages are printed out? Please add error messages to your question.

chapulina gravatar imagechapulina ( 2015-09-09 01:13:02 -0600 )edit

In addion to the questions above. is this isue related to a specific world or all worlds? What Geforce card do you have? Do you use the noveau or the proprietary NVIDIA-Driver?

evilBiber gravatar imageevilBiber ( 2015-09-09 03:02:36 -0600 )edit

The Geforce card installed in my system is NVIDIA GeForce 820M

Jeane gravatar imageJeane ( 2015-09-10 23:41:36 -0600 )edit

I do not use noveau for the graphics card. How to install noveau. Please could you share the link.

Jeane gravatar imageJeane ( 2015-09-11 05:23:13 -0600 )edit

that's the default open source nvidia driver under ubuntu. If you haven't changed it you might have to install the proprietary nvidia driver... It might also be the case that you have to use bumblebee to start GAZEBO (in case you have a hybrid card...)
you can also look at the ~/.gazebo/Ogre.log because there might be information about your problem...

evilBiber gravatar imageevilBiber ( 2015-09-14 02:00:03 -0600 )edit