Home | Tutorials | Wiki | Issues
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

spawning before simulator is ready?

I've just upgraded for ROS-I/Gazebo2 to ROS-K/Gazebo7. If I spawn my robot at the same time Gazebo launches, it gets kicked around in the environment with random velocities. If I spawn the robot after Gazebo launches, all is good.

Any ideas why this might be happening? I've verified that my robot is not in collision with the ground plane, and I can reproduce the error in an empty world.

spawning before simulator is ready?

I've just upgraded for ROS-I/Gazebo2 to ROS-K/Gazebo7. If I spawn my robot at the same time Gazebo launches, it gets kicked around in the environment with random velocities. If I spawn the robot after Gazebo launches, all is good.

Any ideas why this might be happening? I've verified that my robot is not in collision with the ground plane, and I can reproduce the error in an empty world.

spawning before simulator gazebo 7 is ready?ready - model gets kicked around.

I've just upgraded for ROS-I/Gazebo2 to ROS-K/Gazebo7. If I spawn my robot at the same time Gazebo launches, it gets kicked around in the environment with random velocities. Once it settles down, I can reset the pose and it behaves as expected.

If I spawn the robot after Gazebo launches, all is good.

Any ideas why this might be happening? I've verified that my robot is not in collision with the ground plane, and I can reproduce the error in an empty world.world. For now, I'm launching the robot and the environment separately.