Home | Tutorials | Wiki | Issues
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

gzclient tries to load mesh with absolute filename

Hi all,

I'm having the gzserver and rosmaster running on a server.

I'm launching my URDF model into the gazebo simulation server and then try to visualize it by launching the gzclient on my local machine.

Strangely, it tries to load the meshes with the absolute path of the server machine and of course it errors, because it can't find the meshes. My URDF points to the meshes like this: package://my_description/meshes/my_mesh.dae

Then on my local machine, the error is: [Err] [Visual.cc:2726] No mesh specified [Err] [SystemPaths.cc:410] File or path does not exist["/home/my_server/my_ws/src/my_description/meshes/wheel_front.dae"] [Err] [Visual.cc:2726] No mesh specified [Err] [SystemPaths.cc:410] File or path does not exist["/home/my_server/my_ws/src/my_description/meshes/wheel_front.dae"] [Err] [Visual.cc:2366] No mesh found, setting mesh to a unit box

gzclient tries to load mesh with absolute filename

Hi all,

I'm having the gzserver and rosmaster running on a server.

I'm launching my URDF model into the gazebo simulation server and then try to visualize it by launching the gzclient on my local machine.

Strangely, it tries to load the meshes with the absolute path of the server machine and of course it errors, because it can't find the meshes. My URDF points to the meshes like this: package://my_description/meshes/my_mesh.dae

Then on my local machine, the error is: is:

[Err] [Visual.cc:2726] No mesh specified
[Err] [SystemPaths.cc:410] File or path does not exist["/home/my_server/my_ws/src/my_description/meshes/wheel_front.dae"]
[Err] [Visual.cc:2726] No mesh specified
[Err] [SystemPaths.cc:410] File or path does not exist["/home/my_server/my_ws/src/my_description/meshes/wheel_front.dae"]
[Err] [Visual.cc:2366] No mesh found, setting mesh to a unit box

box

gzclient tries to load mesh with absolute filename

Hi all,

I'm having the gzserver and rosmaster running on a server.

I'm launching my URDF model into the gazebo simulation server and then try to visualize it by launching the gzclient on my local machine.

Strangely, it tries to load the meshes with the absolute path of the server machine and of course it errors, because it can't find the meshes. My URDF points to the meshes like this: this:

package://my_description/meshes/my_mesh.dae

Then on my local machine, the error is:

[Err] [Visual.cc:2726] No mesh specified
[Err] [SystemPaths.cc:410] File or path does not exist["/home/my_server/my_ws/src/my_description/meshes/wheel_front.dae"]
[Err] [Visual.cc:2726] No mesh specified
[Err] [SystemPaths.cc:410] File or path does not exist["/home/my_server/my_ws/src/my_description/meshes/wheel_front.dae"]
[Err] [Visual.cc:2366] No mesh found, setting mesh to a unit box