Home | Tutorials | Wiki | Issues
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Installing Gazebo from source on Ubuntu 14.04 : Unable to locate package libqwt-qt5-dev

Hi,

I am trying to install Gazebo from source on Ubuntu 14.04 (would wish to be on 16.04 but I unfortunately need another library for my project which is only supported on 14.04...).

So I followed the procedure found here : http://gazebosim.org/tutorials?cat=install&tut=install_from_source&ver=default

and while installing the dependencies, at step 3 "Install prerequisites", got this message error :

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libqwt-qt5-dev

I understand I don't have libqwt-qt5-dev, but when trying to install it :

sudo apt-get install libqwt-qt5-dev

I get :

E: Unable to locate package libqwt-qt5-dev

Not sure, but looking at this, it seems that the library has no package for 14.04 : http://packages.ubuntu.com/search?keywords=libqwt-qt5-dev

So... my question would be what is the most recent version of Gazebo to use in 14.04 and how to install it from source? Even when I change the Gazebo version in the tutorial, I get the same procedure (or maybe I do not see the difference).

Thanks in advance, any help is really appreciated.

Regards,

David