Home | Tutorials | Wiki | Issues
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Compilation fails as gazebo and ignition-msgs require different protobuf versions

When compiling latest sources for Gazebo on ubuntu 16.04, I get the following error:

This file was generated by an older version of protoc which is incompatible with your Protocol Buffer headers. Please regenerate this file with a newer version of protoc.

Well, in fact looks less tidy:

image description

I tried to downgrade protobuf version to 2.6 (the one required by currently installed ignition-msgs), but... then compilation fails because 2.6 is too old for current gazebo code. I also tried to install ignition-msgs from sources, but it installs only msgs1 messages, while gazebo compilation fails with msg0 (honestly, I have no idea what all this msg0, 1, 2... mean).

Any suggestion? Thanks!