Home | Tutorials | Wiki | Issues
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

How can I set the preserveWorldVelocity flag (hopefully through roslaunch and urdf)?

In order to get rid of unwanted behavior in Gazebo 7, I have installed Gazebo 9 in hopes of setting the preserveWorldVelocity flag. (Is "flag" the proper term?) I'm using roslaunch and xacro to start my simulation. In the robot xacro I have

<gazebo>
  <self_collide>1</self_collide>
</gazebo>

but trying something similar with

<preserveWorldVelocity>1</preserveWorldVelocity>

has no effect. Can you tell me how to set this flag so that using PositionJointInterface does not mean velocities are repeatedly cleared?

How can I set the preserveWorldVelocity flag (hopefully through roslaunch and urdf)?

In order to get rid of unwanted behavior in Gazebo 7, I have installed Gazebo 9 in hopes of setting the preserveWorldVelocity flag. (Is "flag" the proper term?) I'm using roslaunch and xacro to start my simulation. In the robot xacro I have

<gazebo>
  <self_collide>1</self_collide>
</gazebo>

but trying something similar with

<preserveWorldVelocity>1</preserveWorldVelocity>

has no effect. Can you tell me how to set this flag so that using PositionJointInterface does not mean velocities are repeatedly cleared?

How can I set the preserveWorldVelocity flag (hopefully in Gazebo 9(hopefully through roslaunch and urdf)?

In order to get rid of unwanted behavior in Gazebo 7, I have installed Gazebo 9 in hopes of setting the preserveWorldVelocity flag. (Is "flag" the proper term?) I'm using roslaunch and xacro to start my simulation. In the robot xacro I have

<gazebo>
  <self_collide>1</self_collide>
</gazebo>

but trying something similar with

<preserveWorldVelocity>1</preserveWorldVelocity>

has no effect. Can you tell me how to set this flag so that using PositionJointInterface does not mean velocities are repeatedly cleared?