Home | Tutorials | Wiki | Issues
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Is there any way how to synchronize two Gazebo simulations so they always run with the same time?

I am trying to run two Gazebo simulations and always run into the errors of type "Jump back in time detected". It seems to be a problem especially for the tf. I assume the problem occurs when one simulation is in the time of, for example, 1:30 and suddenly gets a message from time 1:25, or so.

It might be also sufficient to just turn off the checking of jumps in time. Is that possible?

How do I achieve consistent time across multiple Gazebo simulations?