Home | Tutorials | Wiki | Issues
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

gazebo1.8+drcsim2.6 fails starting

using: drcsim 2.6 + gazebo 1.8.2

After we followed the given instructions in DRC install ... When starting >> roslaunch atlas_utils atlas.launch << this start fails like follows:

... logging to /home/everybody/.ros/log/37d7cb22-c85b-11e2-92b5-b4b52fc222cb/roslaunch-RitterROSt-26220.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.
started roslaunch server http://RitterROSt:55592/
SUMMARY
========
PARAMETERS
 * /atlas/delay_max_per_step
 * /atlas/delay_max_per_window
 * /atlas/delay_window_size
 * /atlas/time_to_unpin
 * /atlas_controller/gains/back_lbz/d
 * /atlas_controller/gains/back_lbz/i
 * /atlas_controller/gains/back_lbz/i_clamp
 * /atlas_controller/gains/back_lbz/p
  .... snipppp .....
 * /use_sim_time
NODES
  /multisense_sl/camera/
    stereo_proc (stereo_image_proc/stereo_image_proc)
  /
    atlas_robot_state_publisher (robot_state_publisher/state_publisher)
    gazebo (atlas_utils/run_gazebo)
    multisense_sl_robot_state_publisher (robot_state_publisher/state_publisher)
    tf2_buffer_server (tf2_ros/buffer_server)
ROS_MASTER_URI=http://localhost:11311
core service [/rosout] found
process[gazebo-1]: started with pid [26238]
process[atlas_robot_state_publisher-2]: started with pid [26245]
process[multisense_sl_robot_state_publisher-3]: started with pid [26266]
process[tf2_buffer_server-4]: started with pid [26286]
process[multisense_sl/camera/stereo_proc-5]: started with pid [26329]
Error [ConnectionManager.cc:88] Connection Manager is not running
[gazebo-1] process has finished cleanly

Showing us that connection manager could not start propperly. We cannot find the reason for that.

When starting >>gazebo gazebo_ros_depth_camera.world<<

this starts successfully as long as we do not source /usr/share/drcsim/setup.sh

When we souce that file also our plain (w/o drcsim) gazebo fails starting.

The drcsim-ros-nodes seem to have started without errors. What can we do to get drcsim up and running?

Thanks in advance

--jens

gazebo1.8+drcsim2.6 fails starting

using: drcsim 2.6 + gazebo 1.8.2

After we followed the given instructions in DRC install ... When starting >> roslaunch atlas_utils atlas.launch << this start fails like follows:

... logging to /home/everybody/.ros/log/37d7cb22-c85b-11e2-92b5-b4b52fc222cb/roslaunch-RitterROSt-26220.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.
started roslaunch server http://RitterROSt:55592/
SUMMARY
========
PARAMETERS
 * /atlas/delay_max_per_step
 * /atlas/delay_max_per_window
 * /atlas/delay_window_size
 * /atlas/time_to_unpin
 * /atlas_controller/gains/back_lbz/d
 * /atlas_controller/gains/back_lbz/i
 * /atlas_controller/gains/back_lbz/i_clamp
 * /atlas_controller/gains/back_lbz/p
  .... snipppp .....
 * /use_sim_time
NODES
  /multisense_sl/camera/
    stereo_proc (stereo_image_proc/stereo_image_proc)
  /
    atlas_robot_state_publisher (robot_state_publisher/state_publisher)
    gazebo (atlas_utils/run_gazebo)
    multisense_sl_robot_state_publisher (robot_state_publisher/state_publisher)
    tf2_buffer_server (tf2_ros/buffer_server)
ROS_MASTER_URI=http://localhost:11311
core service [/rosout] found
process[gazebo-1]: started with pid [26238]
process[atlas_robot_state_publisher-2]: started with pid [26245]
process[multisense_sl_robot_state_publisher-3]: started with pid [26266]
process[tf2_buffer_server-4]: started with pid [26286]
process[multisense_sl/camera/stereo_proc-5]: started with pid [26329]
Error [ConnectionManager.cc:88] Connection Manager is not running
[gazebo-1] process has finished cleanly

Showing us that connection manager could not start propperly. We cannot find the reason for that.

When starting >>gazebo gazebo_ros_depth_camera.world<<

this starts successfully as long as we do not source /usr/share/drcsim/setup.sh

When we souce that file also our plain (w/o drcsim) gazebo fails starting.

The drcsim-ros-nodes seem to have started without errors. What can we do to get drcsim up and running?

Thanks in advance

--jens

Edit:

Starting >>gazebo gazebo_ros_depth_camera.world<<

with source /usr/share/drcsim/setup.sh

Gazebo itself starts, but the plugin doesn't start while the plugin runs properly w/o source /usr/share/drcsim/setup.sh

everybody@RitterROSt:~/catkin_ws/src/gazebo_pkgs/gazebo_plugins/test/test_worlds$ source /usr/share/drcsim/setup.sh
everybody@RitterROSt:~/catkin_ws/src/gazebo_pkgs/gazebo_plugins/test/test_worlds$ gazebo gazebo_ros_depth_camera.world
Gazebo multi-robot simulator, version 1.8.2
Copyright (C) 2013 Open Source Robotics Foundation.
Released under the Apache 2 License.
http://gazebosim.org

Gazebo multi-robot simulator, version 1.8.2
Copyright (C) 2013 Open Source Robotics Foundation.
Released under the Apache 2 License.
http://gazebosim.org

Msg Waiting for master.Warning [parser.cc:361] Converting a deprecated SDF source[/home/everybody/catkin_ws/src/gazebo_pkgs/gazebo_plugins/test/test_worlds/gazebo_ros_depth_camera.world].
Warning [Converter.cc:58]   Version[1.3] to Version[1.4]
  Please use the gzsdf tool to update your SDF files.
    $ gzsdf convert [sdf_file]
Warning [parser.cc:499] XML Attribute[near] in element[clip] not defined in SDF, ignoring.
Warning [parser.cc:499] XML Attribute[far] in element[clip] not defined in SDF, ignoring.
Warning [parser.cc:499] XML Attribute[path] in element[save] not defined in SDF, ignoring.
Warning [parser.cc:499] XML Attribute[output] in element[depth_camera] not defined in SDF, ignoring.
Msg Waiting for master
Msg Connected to gazebo master @ http://127.0.0.1:11345
Msg Publicized address: 172.17.240.130
Warning [ODEPhysics.cc:204] Gravity vector is (0, 0, 0). Objects will float.
Error [Plugin.hh:126] Failed to load plugin libgazebo_ros_depth_camera.so: libgazebo_ros_depth_camera.so: cannot open shared object file: No such file or directory

Msg Connected to gazebo master @ http://127.0.0.1:11345
Msg Publicized address: 172.17.240.130
Error [Param.hh:249] Unable to set value [1,0471975511965976] for key[horizontal_fov]
Error [Param.hh:249] Unable to set value [0,100000001] for key[near]