Home | Tutorials | Wiki | Issues
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Unable to install drcsim and gazebo on Ubuntu 12.04 or 12.10

When i try to install drcsim, gazebo, or ros i get the following errors on both Ubuntu 12.04 as well as 12.10. I have tried multiple times to install and have the followed the directions on the site. I get the following errors when i try.

Building dependency tree
Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: drcsim : Depends: gazebo (>= 1.2.0) but it is not going to be installed Depends: ros-fuerte-pr2-mechanism but it is not going to be installed Depends: ros-fuerte-std-msgs but it is not going to be installed Depends: ros-fuerte-common-msgs but it is not going to be installed Depends: ros-fuerte-image-common but it is not going to be installed Depends: ros-fuerte-geometry but it is not going to be installed Depends: ros-fuerte-pr2-controllers but it is not going to be installed Depends: ros-fuerte-geometry-experimental but it is not going to be installed Depends: ros-fuerte-robot-model-visualization but it is not going to be installed E: Unable to correct problems, you have held broken packages.

Unable to install drcsim and gazebo on Ubuntu 12.04 or 12.10

When i try to install drcsim, gazebo, or ros i get the following errors on both Ubuntu 12.04 as well as 12.10. I have tried multiple times to install and have the followed the directions on the site. I get the following errors when i try.

Building dependency tree
Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: drcsim : Depends: gazebo (>= 1.2.0) but it is not going to be installed Depends: ros-fuerte-pr2-mechanism but it is not going to be installed Depends: ros-fuerte-std-msgs but it is not going to be installed Depends: ros-fuerte-common-msgs but it is not going to be installed Depends: ros-fuerte-image-common but it is not going to be installed Depends: ros-fuerte-geometry but it is not going to be installed Depends: ros-fuerte-pr2-controllers but it is not going to be installed Depends: ros-fuerte-geometry-experimental but it is not going to be installed Depends: ros-fuerte-robot-model-visualization but it is not going to be installed E: Unable to correct problems, you have held broken packages.

Unable to install drcsim and gazebo on Ubuntu 12.04 or 12.10

When i try to install drcsim, gazebo, or ros i get the following errors on both Ubuntu 12.04 as well as 12.10. I have tried multiple times to install and have the followed the directions on the site. I get the following errors when i try.

Building dependency tree 
Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

situation: The following packages have unmet dependencies: drcsim : Depends: gazebo (>= 1.2.0) but it is not going to be installed Depends: ros-fuerte-pr2-mechanism but it is not going to be installed Depends: ros-fuerte-std-msgs but it is not going to be installed Depends: ros-fuerte-common-msgs but it is not going to be installed Depends: ros-fuerte-image-common but it is not going to be installed Depends: ros-fuerte-geometry but it is not going to be installed Depends: ros-fuerte-pr2-controllers but it is not going to be installed Depends: ros-fuerte-geometry-experimental but it is not going to be installed Depends: ros-fuerte-robot-model-visualization but it is not going to be installed E: Unable to correct problems, you have held broken packages.

packages.