Home | Tutorials | Wiki | Issues
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

DRCSim 1.2/1.3 With Gazebo Crashes(exits) often when moving the base using cmd_vel topic

Using either DRCSim 1.2 or 1.3 compiled from source with Gazebo 1.3.1 I experience gazebo exiting when I move the robot's pinned pelvis around using the /cmd_vel topic. (1.3 is /atlas/cmd_vel)

I've noticed that this seems to usually happen when the robot is slowing down and almost stopped, but that is probably just a coincidence. I've tried running gazebo in gdb but it just says that the process exits cleanly, so I can't get any sort of stack trace.

DRCSim 1.2/1.3 With Gazebo Crashes(exits) often when moving the base using cmd_vel topic

Using either DRCSim 1.2 or 1.3 compiled from source with Gazebo 1.3.1 I experience gazebo exiting when I move the robot's pinned pelvis around using the /cmd_vel topic. (1.3 is /atlas/cmd_vel)

I've noticed that this seems to usually happen when the robot is slowing down and almost stopped, but that is probably just a coincidence. I've tried running gazebo in gdb but it just says that the process exits cleanly, so I can't get any sort of stack trace.

Edit: I also think its worth mentioning that the Hokuyo is spinning while the robot is moving around.

click to hide/show revision 3
Added stack trace & more information.

DRCSim 1.2/1.3 With Gazebo Crashes(exits) often when moving the base using cmd_vel topic

Using either DRCSim 1.2 or 1.3 compiled from source with Gazebo 1.3.1 I experience gazebo exiting when I move the robot's pinned pelvis around using the /cmd_vel topic. (1.3 is /atlas/cmd_vel)

I've noticed that this seems to usually happen when the robot is slowing down and almost stopped, but that is probably just a coincidence. I've tried running gazebo in gdb but it just says that the process exits cleanly, so I can't get any sort of stack trace. trace.

Edit: I also think its worth mentioning that the Hokuyo is spinning while the robot is moving around.

Edit2: Okay, I found the reason I wasn't getting a stacktrace is because the gdb was attached to the gzclient and not gzserver (since I was running gdb gazebo, and it forks both off). I've been able to generate the crash with the stack trace posted here: http://pastebin.com/LYv3tt8t

The crash is in heightfield.cpp, and I should mention that I am using the drc_sim_v0.launch launch file in atlas_utils.

DRCSim 1.2/1.3 With Gazebo Crashes(exits) often when moving the base using cmd_vel topic

Using either DRCSim 1.2 or 1.3 compiled from source with Gazebo 1.3.1 I experience gazebo exiting when I move the robot's pinned pelvis around using the /cmd_vel topic. (1.3 is /atlas/cmd_vel)

I've noticed that this seems to usually happen when the robot is slowing down and almost stopped, but that is probably just a coincidence. I've tried running gazebo in gdb but it just says that the process exits cleanly, so I can't get any sort of stack trace.

Edit: I also think its worth mentioning that the Hokuyo is spinning while the robot is moving around.

Edit2: Okay, I found the reason I wasn't getting a stacktrace is because the gdb was attached to the gzclient and not gzserver (since I was running gdb gazebo, and it forks both off). I've been able to generate the crash with the stack trace posted here: http://pastebin.com/LYv3tt8t

The crash is in heightfield.cpp, and I should mention that I am using the drc_sim_v0.launch launch file in atlas_utils.

DRCSim 1.2/1.3 With Gazebo Crashes(exits) Crashes often when moving the base using cmd_vel topic

Using either DRCSim 1.2 or 1.3 compiled from source with Gazebo 1.3.1 I experience gazebo exiting when I move the robot's pinned pelvis around using the /cmd_vel topic. (1.3 is /atlas/cmd_vel)

I've noticed that this seems to usually happen when the robot is slowing down and almost stopped, but that is probably just a coincidence. I've tried running gazebo in gdb but it just says that the process exits cleanly, so I can't get any sort of stack trace.

Edit: I also think its worth mentioning that the Hokuyo is spinning while the robot is moving around.

Edit2: Okay, I found the reason I wasn't getting a stacktrace is because the gdb was attached to the gzclient and not gzserver (since I was running gdb gazebo, and it forks both off). I've been able to generate the crash with the stack trace posted here: http://pastebin.com/LYv3tt8t

The crash is in heightfield.cpp, and I should mention that I am using the drc_sim_v0.launch launch file in atlas_utils.

DRCSim 1.2/1.3 With Gazebo Crashes often when moving the base using cmd_vel topic

Using either DRCSim 1.2 or 1.3 compiled from source with Gazebo 1.3.1 I experience gazebo exiting when I move the robot's pinned pelvis around using the /cmd_vel topic. (1.3 is /atlas/cmd_vel)

I've noticed that this seems to usually happen when the robot is slowing down and almost stopped, but that is probably just a coincidence. I've tried running gazebo in gdb but it just says that the process exits cleanly, so I can't get any sort of stack trace.

Edit: I also think its worth mentioning that the Hokuyo is spinning while the robot is moving around.

Edit2: Okay, I found the reason I wasn't getting a stacktrace is because the gdb was attached to the gzclient and not gzserver (since I was running gdb gazebo, and it forks both off). I've been able to generate the crash with the stack trace posted here: http://pastebin.com/LYv3tt8t

The crash is in heightfield.cpp, and I should mention that I am using the drc_sim_v0.launch launch file in atlas_utils.

DRCSim 1.2/1.3 With Gazebo Crashes often when moving the base using cmd_vel topic

Using either DRCSim 1.2 or 1.3 compiled from source with Gazebo 1.3.1 I experience gazebo exiting when I move the robot's pinned pelvis around using the /cmd_vel topic. (1.3 is /atlas/cmd_vel)

I've noticed that this seems to usually happen when the robot is slowing down and almost stopped, but that is probably just a coincidence. I've tried running gazebo in gdb but it just says that the process exits cleanly, so I can't get any sort of stack trace.

Edit: I also think its worth mentioning that the Hokuyo is spinning while the robot is moving around.

Edit2: Okay, I found the reason I wasn't getting a stacktrace is because the gdb was attached to the gzclient and not gzserver (since I was running gdb gazebo, and it forks both off). I've been able to generate the crash with the stack trace posted here: http://pastebin.com/LYv3tt8t

The crash is in heightfield.cpp, and I should mention that I am using the drc_sim_v0.launch launch file in atlas_utils.

DRCSim 1.2/1.3 With Gazebo Crashes often when moving the base using cmd_vel topic

Using either DRCSim 1.2 or 1.3 compiled from source with Gazebo 1.3.1 I experience gazebo exiting when I move the robot's pinned pelvis around using the /cmd_vel topic. (1.3 is /atlas/cmd_vel)

I've noticed that this seems to usually happen when the robot is slowing down and almost stopped, but that is probably just a coincidence. I've tried running gazebo in gdb but it just says that the process exits cleanly, so I can't get any sort of stack trace.

Edit: I also think its worth mentioning that the Hokuyo is spinning while the robot is moving around.

Edit2: Okay, I found the reason I wasn't getting a stacktrace is because the gdb was attached to the gzclient and not gzserver (since I was running gdb gazebo, and it forks both off). I've been able to generate the crash with the stack trace posted here: http://pastebin.com/LYv3tt8t

Edit3: I'm pretty sure this is a bug, and I've reported it. https://bitbucket.org/osrf/gazebo/issue/339/laserscan-causes-gazebo-to-crash-when

The crash is in heightfield.cpp, and I should mention that I am using the drc_sim_v0.launch launch file in atlas_utils.