Home | Tutorials | Wiki | Issues
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Failed to load plugin, no such file or directory, Gazebo 5.0 with ROS

Hi everyone,

I've been reading through many similar questions and trying their solutions however with no avail. I'm fairly new to Gazebo and while I've tried some other solutions, it may not have worked due to vagueness in the answer, differences over the different Gazebo versions or I may have simply missed something obvious. It seems upon trying to load any plugin, either my own or given Gazebo examples, it fails to load with the error below.

[Err] [Plugin.hh:153] Failed to load plugin libmodel_push.so: libmodel_push.so: cannot open shared object file: No such file or directory

I'm using Gazebo 5.0 with ROS, installed from source, running on Ubuntu, my GAZEBO_PLUGIN_PATH was originally empty by default, It now contains "/home/elias/catkin_ws/devel"

Does anyone have any ideas or solutions?

Thanks in advance.