Home | Tutorials | Wiki | Issues
Ask Your Question

bmenendez's profile - activity

2017-05-08 11:18:10 -0600 received badge  Taxonomist
2015-01-22 12:36:24 -0600 received badge  Famous Question (source)
2015-01-22 12:36:24 -0600 received badge  Notable Question (source)
2013-07-25 01:24:28 -0600 received badge  Famous Question (source)
2013-07-23 18:41:47 -0600 received badge  Popular Question (source)
2013-06-05 13:47:57 -0600 answered a question Gazebo 1.8.1 turns into black

Ok, thanks to ffurrer I know what was the problem. In his example:

  <collision name="collision">
    <geometry>
      <heightmap>
        <uri>model://vrc_heightmap_1/materials/textures/heightmap.png</uri>
        <size>500 500 118</size>
        <pos>0 0 -15</pos>
      </heightmap>
    </geometry>
  </collision>

I didn't add the "collision".

Thank you!!!! :D

2013-06-05 13:47:05 -0600 received badge  Scholar (source)
2013-06-05 13:46:54 -0600 received badge  Notable Question (source)
2013-06-05 13:44:37 -0600 commented answer Gazebo 1.8.1 turns into black

Hi ffurrer. First of all, thank you for your answer :) I tried before to load another world and that's ok, it loads the world properly (for example, I tried to load a world just with the Pioneer 2DX and some walls and it worked). I can also load the model you showed me, so I don't really know where it is failing. The image (jaramaCircuitoRetocado.png) is just a black&white image and it works in Ubuntu 12.04 without graphic drivers but not in Ubuntu 13.04 with graphic drivers :-/

2013-06-05 07:33:47 -0600 received badge  Popular Question (source)
2013-06-01 14:05:42 -0600 asked a question Gazebo 1.8.1 turns into black

Hello,

I'm trying to launch my own world of a circuit but it is not possible, Gazebo turns into black and I cannot see my world with my robot. I can connect to the robot cameras but I don't see anything. The model of the circuit is the following:

<?xml version="1.0" ?>
<sdf version="1.4">
  <model name="heightmap">
    <static>true</static>
    <link name="link2">
      <visual name="visual">
        <geometry>
          <heightmap>     
            <texture>
              <diffuse>file://media/materials/textures/terrain_detail.jpg</diffuse>
              <normal>file://media/materials/textures/terrain_detail.jpg</normal>
              <size>50</size>
            </texture>
            <texture>
              <diffuse>file://media/materials/textures/flat_normal.png</diffuse>
              <normal>file://media/materials/textures/flat_normal.png</normal>
              <size>50</size>
            </texture>
            <texture>
              <diffuse>file://media/materials/textures/beigeWall.jpg</diffuse>
              <normal>file://media/materials/textures/flat_normal.png</normal>
              <size>20</size>
            </texture>  
            <blend>
              <min_height>0</min_height>
              <fade_dist>0</fade_dist>
            </blend>
            <blend>
              <min_height>0.01</min_height>
              <fade_dist>0</fade_dist>
            </blend>     
            <uri>model://jarama/images/jaramaCircuitoRetocado.png</uri>
            <size>50 50 1</size>
            <pos>0 0 0</pos>
          </heightmap>
        </geometry>
      </visual>
    </link>
  </model>
</sdf>

Basically it loads a black&white image with the circuit and constructs it with walls and a blue line. It is to do a follow-line behaviour based on the Pioneer 2DX.

I'm running Gazebo on Ubuntu 13.04 64bits. In Ubuntu 12.04 64bits I can load this world but it works so slowly because of not having drivers of my integrated graphic card (Intel HD4000), now developed for Ubuntu 13.04.

Do you know if I'm missing something or if I can fix that?

Thank you,

Borja.

2013-05-31 05:49:29 -0600 commented question Compile without tests to build a debian package

Just commented the line "enable_testing()" and can complete the packaging :)

2013-05-31 04:19:59 -0600 asked a question Compile without tests to build a debian package

Hello,

I'm making the debian package for Debian of Gazebo 1.8.2 but I'm doing that in a chroot directory, so I do not have display output and tests doesn't pass. What I want is to disable tests to build the package for Debian, do you know if there is a way to do that? Or just simply remove the "test" folder? Or there is another way to pass the tests and build the package?

I commented all lines referring to "test" but it stopped at 85%, when linking to msgs_TEST:

/usr/bin/ld: cannot find -lgtest /usr/bin/ld: cannot find -lgtestmain collect2: error: ld returned 1 exit status make[3]: * [gazebo/msgs/msgsTEST] Error 1 make[3]: Leaving directory /root/jderobot-gazebo-5.1.2/obj-i486-linux-gnu' make[2]: *** [gazebo/msgs/CMakeFiles/msgs_TEST.dir/all] Error 2 make[2]: Leaving directory/root/jderobot-gazebo-5.1.2/obj-i486-linux-gnu' make[1]: * [all] Error 2 make[1]: Leaving directory `/root/jderobot-gazebo-5.1.2/obj-i486-linux-gnu' dhautobuild: make -j1 returned exit code 2

Thanks!

Borja.