Home | Tutorials | Wiki | Issues
Ask Your Question

RafBerkvens's profile - activity

2014-03-01 07:48:38 -0600 received badge  Famous Question (source)
2013-11-07 10:26:50 -0600 received badge  Famous Question (source)
2013-11-07 10:26:50 -0600 received badge  Notable Question (source)
2013-10-22 08:09:11 -0600 received badge  Famous Question (source)
2013-10-22 07:46:30 -0600 received badge  Notable Question (source)
2013-10-19 20:30:42 -0600 received badge  Student (source)
2013-10-18 04:53:52 -0600 commented answer Error 141: libgazebo_ros_control can not be found in Gazebo 2.0.0

You have to remove the OSRF repo from your apt sources. Go to System Settings > Software & Updates > Other Software. Look for http://packages.osrfoundation.org/gazebo/ubuntu and untick or remove that line. Then run sudo apt-get update, sudo apt-get remove gazebo-current ros-hydro-desktop-full, sudo apt-get autoremove, sudo apt-get install ros-hydro-desktop-full. Now, you should have Gazebo 1.9.2 and able to install ros-hydro-gazebo-ros-control.

2013-10-17 19:47:10 -0600 received badge  Notable Question (source)
2013-10-17 11:32:18 -0600 received badge  Popular Question (source)
2013-10-17 07:58:34 -0600 commented answer Error 141: libgazebo_ros_control can not be found in Gazebo 2.0.0

Indeed, I am running raring. I should have mentioned that, my apologies. I will try your suggestion.

2013-10-17 01:48:27 -0600 commented answer Error 141: libgazebo_ros_control can not be found in Gazebo 2.0.0

Could it be that ros-hydro-gazebo-ros-control is not a package that is maintained under Gazebo 2.0.0? It still looks for gazebo when installing through the repositories.

2013-10-17 01:18:17 -0600 commented answer Error 141: libgazebo_ros_control can not be found in Gazebo 2.0.0

According to those instructions, Gazebo 1.9.2 would be installed when installing ROS. I purged all gazebo, gazebo-current, ros-hydro-desktop-full, ros-hydro-gazebo-* packages from my system and did a fresh ros-hydro-desktop-full install. It automatically selects gazebo-current. The ros-hydro-gazebo-ros-control packages can still not be installed, because they look for gazebo.

2013-10-16 11:54:14 -0600 received badge  Popular Question (source)
2013-10-16 08:51:36 -0600 asked a question Error 141: libgazebo_ros_control can not be found in Gazebo 2.0.0

When running my simulation using Gazebo 2.0.0, I get the following non-critical error:

Error [Plugin.hh:141] Failed to load plugin libgazebo_ros_control.so: 
libgazebo_ros_control.so: cannot open shared object file: No such file or directory

I don't use the ROS control part of the simulation for now, so it doesn't matter too much. However, I thought I should mention it here. I think that the current ros-hydro-gazebo-ros-control package might still be linked against Gazebo 1.9.

2013-10-16 04:10:10 -0600 answered a question Gazebo crashes on simulating gpu_ray

The solution was, of course, simple.

The model used the libgazebo_ros_gpu_laser.so. Since Gazebo proved to be unable to run on virtual GPU ussage (export LIBGL_ALWAYS_SOFTWARE=1 was necessary to run Gazebo using hardware acceleration), it could not access the GPU. Changing the plugin to libgazebo_ros_laser.so and sensor type to ray solved the issue.

The hint was found in this discussion: https://bitbucket.org/osrf/gazebo/issue/760/uneven-sdf-model-updates-cuase, which was found thanks to the backtrace suggested by @nkoening.

2013-10-16 02:15:41 -0600 commented question Gazebo crashes on simulating gpu_ray

I have tested the setup with the new Gazebo 2.0. The backtrace is the same.

2013-10-16 02:03:58 -0600 received badge  Editor (source)
2013-10-15 10:08:22 -0600 received badge  Nice Answer (source)
2013-10-15 08:35:06 -0600 commented question Gazebo crashes on simulating gpu_ray

I thought to have solved it by installing ros-hydro-hokuyo-node, but it results in the same error. The libGL errors can be resolved by turning on 3D acceleration and using export LIBGL_ALWAYS_SOFTWARE=1, but this does also not resolve the segmentation fault when the range readings are requested.

2013-10-15 05:07:04 -0600 asked a question Gazebo crashes on simulating gpu_ray

My situation is the following: I have a working robot model with a head_hokuyo_sensor as laser range finder. When using this model on my default setup, everything works fine. When using the model on a virtual machine, Gazebo crashes when the range readings are requested.

At first I thought Gazebo crashed any time when launched in the virtual machine. This is not true. It only crashes when the range readings are requested, either by visualization (as was default in my first try), or by ROS rviz. This is the output when the model is launched and the data is requested by rviz:

$ roslaunch p3dx_gazebo gazebo.launch 
... logging to /home/gazebo/.ros/log/0c658438-357b-11e3-952c-080027a2ea94/roslaunch-gazebo-VirtualBox-10513.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://gazebo-VirtualBox:44541/

SUMMARY
========

PARAMETERS
 * /robot_description
 * /rosdistro
 * /rosversion
 * /use_sim_time

NODES
  /
    gazebo (gazebo_ros/gzserver)
    gazebo_gui (gazebo_ros/gzclient)
    urdf_spawner (gazebo_ros/spawn_model)

ROS_MASTER_URI=http://localhost:11311

core service [/rosout] found
process[gazebo-1]: started with pid [10534]
process[gazebo_gui-2]: started with pid [10539]
process[urdf_spawner-3]: started with pid [10546]
Gazebo multi-robot simulator, version 1.9.1
Copyright (C) 2013 Open Source Robotics Foundation.
Released under the Apache 2 License.
http://gazebosim.org

Gazebo multi-robot simulator, version 1.9.1
Copyright (C) 2013 Open Source Robotics Foundation.
Released under the Apache 2 License.
http://gazebosim.org

Msg Waiting for master.spawn_model script started
[ INFO] [1381829287.748584629]: Finished loading Gazebo ROS API Plugin.
[1;[ INFO] [1381829287.754626059]: waitForService: Service [/gazebo/set_physics_properties] has not been advertised, waiting...
32mMsg Waiting for master
Msg Connected to gazebo master @ http://127.0.0.1:11345
Msg Publicized address: 10.0.2.15
OpenGL Warning: Failed to connect to host. Make sure 3D acceleration is enabled for this VM.
libGL error: failed to load driver: vboxvideo
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
[INFO] [WallTime: 1381829287.963248] [0.000000] Loading model xml from ros parameter
[INFO] [WallTime: 1381829287.969376] [0.000000] Waiting for service /gazebo/spawn_urdf_model
[INFO] [WallTime: 1381829288.279075] [0.000000] Calling service /gazebo/spawn_urdf_model

Msg Connected to gazebo master @ http://127.0.0.1:11345
Msg Publicized address: 10.0.2.15
OpenGL Warning: Failed to connect to host. Make sure 3D acceleration is enabled for this VM.
libGL error: failed to load driver: vboxvideo
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
Error [Param.cc:181] Unable to set value [1,0471975511965976] for key[horizontal_fov]
Error [Param.cc:181] Unable to set value [0,100000001] for key[near]
Warning [parser.cc:356] No <sdf> element in file[data-string]
[INFO] [WallTime: 1381829294.465796] [0.001000] Spawn status: SpawnModel: Successfully spawned model
[ INFO] [1381829294.500488438, 0.001000000]: LoadThread function completed
[ INFO] [1381829294.578569308, 0.001000000]: Loading gazebo_ros_control plugin
[ INFO] [1381829294.583119526, 0.001000000]: Starting gazebo_ros_control plugin in namespace: /p3dx
[ INFO] [1381829294.587561148, 0.001000000]: gazebo_ros_control plugin is waiting for model URDF in parameter [/robot_description] on the ROS param server.
[urdf_spawner-3] process has finished cleanly ...
(more)
2013-10-15 04:42:35 -0600 received badge  Supporter (source)
2013-10-14 06:25:25 -0600 received badge  Teacher (source)
2013-10-14 03:02:56 -0600 commented answer problem with loading gazebo in ros

With the proposed shadow ROS debians I can launch Gazebo again, but libgazebo_common.so.1 can still not be found. Are they still compiled against Gazebo 1.9, maybe? I have ros-hydro-gazebo-ros 2.3.3-0raring-20131010-2340-+0000 and gazebo/raring uptodate 2.0.0-1~raring (using apt-show-versions - other gazebo packages omitted due to character limit).

2013-10-14 02:14:11 -0600 answered a question Unmet dependencies during Gazebo ROS pachage installation

This is probably due to the same issue as this question: http://answers.gazebosim.org/question/4630/problem-with-loading-gazebo-in-ros/. Best is to wait until the ROS repository is updated. Alternatives can be found in said question.

2013-10-13 18:20:43 -0600 received badge  Popular Question (source)
2013-10-11 09:26:59 -0600 commented answer problem with loading gazebo in ros

It's now over 13 hours since the issue you mentioned was closed. The problem still persists on my side. They stated that the solution should be available very soon. Did something go wrong?

2013-10-11 01:36:41 -0600 commented answer No gazebo-ros package after update?

Thanks for both the reply and the comment. I'm now waiting for the actual update to happen.

2013-10-11 01:25:33 -0600 received badge  Scholar (source)
2013-10-10 08:58:59 -0600 asked a question No gazebo-ros package after update?

After the recent 2.0.0 Gazebo update, I can no longer run gazebo_ros. It has been deinstalled during the update. When trying to install gazebo-ros-pkgs, I get the following output:

The following packages have unmet dependencies:
 ros-hydro-gazebo-ros-control : Depends: ros-hydro-gazebo-ros but it is not going to be installed
 ros-hydro-gazebo-ros-pkgs : Depends: ros-hydro-gazebo-plugins but it is not going to be installed
                             Depends: ros-hydro-gazebo-ros but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

When trying to install the mentioned ros-hydro-gazebo-ros, this is the output:

The following packages have unmet dependencies:
 ros-hydro-gazebo-ros : Depends: gazebo but it is not going to be installed
                        Depends: ros-hydro-gazebo-plugins but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Yet, gazebo is installed and can be run.

Is there something broken in the repository?