Gazebo | Ignition | Community
Ask Your Question

No contact information returned

asked 2013-02-21 06:11:39 -0500

Boris gravatar image

updated 2013-02-21 23:27:25 -0500

As can be seen from the picture below there is obviously a collision. However no contact information is returned.

At the beginning of collision a lot of data returned, but after the system gets to equilibrium contact information is not longer available.

Is it a bug or I have to tune some simulation parameters? Is there any workaround for this?



image description

EDIT: Here are model and world SDFs.

I just noticed that there is a solver of type quick in my world. Can it be the cause?

EDIT #2: Tried Solver type world, but now I am unable to spawn any objects from gui - Gazebo simply dies.

edit retag flag offensive close merge delete



Hi, are you getting the contacts from messages, or you have your own plugin? If it is a sensor, then seeing the sdf file might also help.

AndreiHaidu gravatar imageAndreiHaidu ( 2013-02-21 07:22:01 -0500 )edit

I have my own plugin, but `$ gztopic echo /gazebo/default/physics/contacts` also shows nothing (except for time).

Boris gravatar imageBoris ( 2013-02-21 07:28:25 -0500 )edit

In your plugin is the sensor active? ( 'this->parentSensor->SetActive(true);' ) But I suppose yes, if you said you get the data at the beginning.

AndreiHaidu gravatar imageAndreiHaidu ( 2013-02-21 08:48:39 -0500 )edit

Yeah, sure, it is active.

Boris gravatar imageBoris ( 2013-02-21 23:25:12 -0500 )edit

Inactive objects get automatically disabled. This will stop collisions from being reported.

nkoenig gravatar imagenkoenig ( 2013-03-07 22:43:15 -0500 )edit

@nkoenig, so what triggers them back to active? Thanks.

Boris gravatar imageBoris ( 2013-03-09 00:58:38 -0500 )edit

there is a <allow_ auto="" _disable=""> tag in within <model> that you can set to false. You can give this a try

iche033 gravatar imageiche033 ( 2013-03-14 02:36:28 -0500 )edit

An active object that collides with an inactive object will make the inactive object active.

nkoenig gravatar imagenkoenig ( 2013-03-17 17:26:11 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2013-07-23 21:26:16 -0500

nkoenig gravatar image

updated 2013-07-23 21:30:32 -0500

A model without links will become inactive when it reaches a resting state.

You can disable this behavior on a per-model basis using the <allow_ auto="" _disable=""> tag in within <model>.

edit flag offensive delete link more


should be like this: <model name="xxx"> <allow_auto_disable>false</allow_auto_disable> .... </model>

wei gravatar imagewei ( 2016-03-25 11:01:09 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower


Asked: 2013-02-21 06:11:39 -0500

Seen: 350 times

Last updated: Jul 23 '13