Gazebo | Ignition | Community
Ask Your Question

Gazebo 3.0 error when running from source

asked 2014-05-07 03:33:11 -0600

AndreiHaidu gravatar image

updated 2014-05-09 07:43:33 -0600

Hi there,

after installing gazebo from source I get the following error when I try to run it:

gazebo: error while loading shared libraries: cannot open shared object file: No such file or directory

in the installation tutorial there is a warning that something similar might happen, however the given commands did not fix the issue.

by running the command with my local installation:

echo '/home/haidu/bin/gazebo_3.0/lib/' | sudo tee /etc/ 
sudo ldconfig

I get the same error.

However, if I use

echo '/home/haidu/bin/gazebo_3.0/lib/x86_64-linux-gnu/' | sudo tee /etc/ 
sudo ldconfig

I get this error.


if I install in to the default location, my libraries are in /usr/local/lib/x86_64-linux-gnu instead of /usr/local/lib , and I get the same error.


In line 6 there is this error:


Meaning that gazebo is trying to run OGRE 1.7.4 instead of 1.8.0 (both versions being available on a fresh Ubuntu 13.04 install, gazebo3 from source being the first thing installed). If I remove OGRE 1.7.4 it complains that it doesn't find CEGUI, which I guess comes with 1.7.4

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2014-05-08 19:23:31 -0600

Jose Luis Rivero gravatar image

I would recommend run a system installation, if possible, it would make things easier. Just by using:


If a system installation is not possible, I would recommend to use LD_LIBRARY_PATH when run gazebo in the following way:

LD_LIBRARY_PATH=/home/andrei/install/lib gazebo


LD_LIBRARY_PATH=/usr/local/lib gazebo
edit flag offensive delete link more
Login/Signup to Answer

Question Tools


Asked: 2014-05-07 03:33:11 -0600

Seen: 953 times

Last updated: May 09 '14